Clicking noise from Rock Pi 4


#1

A few days ago I noticed a rapid clicking noise from my Rock Pi 4 board. It keeps clicking even if I restart the board. I only have one Rock Pi 4 and I can’t compare this to another board. I also can’t say if this clickling noise was there from the beginnig. Is this normal or is something broken on my board?


#2

If you don’t confirm that your ROCK Pi 4 is broken or not, could run a set of stress tests.

For example, Antutu

have the abnormalities in the test process or not


#3

I’ve just run a cpu test using sysbench and I can still hear the clicking during the test. I can also hear the clicking if if shut down the device completely and just having the power connected. I’ve also recorded the sound using my phone: https://www.dropbox.com/s/0dlyst6wcgtr6jv/Audio-Aufnahme%202019-04-08%2019-43-53.wav?dl=0

Any idea what could cause this?

Edit: If I disconnect and reconnect the power there is no clicking, but it starts soon after that when the OS (Ubuntu) is booting. I also tried booting a fresh installation and there is no clicking. So it must be something I installed. I will install everything on the fresh installation again until the clicking appears again to find out what causes this.

Edit2: I think I already found out what is causing this. As soon as I installed the latest version of the kernel I compiled myself the clicking is back. @jack Any ideas what changes to the kernel could cause this clicking?

Edit3: Ignore the last comment. It seems to be much simpler. The clicking also appears after the first reboot of the fresh, unchanged system.


#4

Do you have the HDMI port in use? If yes, can you please use the RockPi headless without HDMI? Is the noise gone then?

If the noise is still there, I could imagine the Buck Converter NB679GD, resp. an inductor, as a possible cause.


#5

bad power supply? (: try another one and compare the noise


#6

@SunWukong: Yes I had an HDMI cable connected to my TV. I disconnected the cable and powered off the device completely and started it again. At first there was no clicking, but it startet again when I rebooted the operating system. Any other ideas?

@MX_Master: I’m using this power supply with an USB-C cable. I will see if I find another power supply that is strong enough for the board and test if this solves the clicking.


#7

@MX_Master I’ve tried a different power supply (Anker PowerPort 5) and I can still hear the clicking. After that I tried powering using a Powerbank and there was no clicking. So it could be an issue regarding the power supply. But I guess the PowerPort 5 should be a pretty good power supply.

@SunWukong Any ideas what could be the problem with my power supply?


#8

Maybe your electricity network have abnormal voltage range and noisy output form. Have you some brightness dimmers at your home?


#9

I have no brightness dimmers. I only use Philipps Hue lamps in my home.

I did some more tests and I found out that the clicking on the battery only stops if I connect the power using an USB-C to USB-C cable. If I connect an USB-A to USB-C cable from the battery I also get the clicking.

I also tried to plug the power supply into a special plug strip that should correct power issues but also had the clicking. Then I also tried connecting the power plug to my USV and there I had no clicking. So it seems to have something to do with the power.

I also noticed that the passive cpu cooler (I use the big one) get’s really hot if the device runs for a few days, even when only the basic operating system runs. Also the device always crashes after a few days of continuous operation.

@MX_Master @SunWukong Could this be an issue with the 50 hz power in europe and could the temperature issue be caused because of this?


#10

Try to power up your board outside of your home (: In the office (at work), for example. Try a power plug at the friend’s home too.

By the way, usb-c cable can provide 3A current, but usb-a - is not. May be it’s an answer (:


#11

I will try that, but an additional test on the USV showed that the board also clicks there sometimes. This seems to be a very random problem. Could my board be damaged or have some kind of manufacturing defect?


#12

Maybe. Maybe not. Need more tests with different power sources.