Can't bring up serial console on rock pi 4b

I’m on mac os (I’ve tried chrome os terminal apps as well, behavior is similar so I won’t go in to it).

ioreg -p IOUSB shows

±o FT232R USB UART@14200000

So far, so good. I also see this device:

crw-rw-rw- 1 root wheel 18, 14 Mar 23 10:35 /dev/tty.usbserial-AQ00KPVD

So I get to the point where I want to connect a terminal, and I get zero output:

sudo screen /dev/tty.usbserial-AQ00KPVD 1500000

What are steps I can take to debug this? I am 100% sure I’ve connected the cable to the correct pinouts on the board, and I’ve worked with a lot of SBCs in the past and never had problems like this connecting to the console.

This is preventing me from seeing the u-boot shell after adb reboot bootloader (I’m running android). I want to put the bootloader in to fastboot mode, so if there’s another way to do that I’d appreciate the workaround for the serial port.

This has the additional unpleasant side effect of the board is stuck rebooting in to bootloader and I have no way to instruct it to go ahead and boot android now.

I’m using ROCK Pi S and USB/UART TTL serial console connection from Kubuntu Linux PC.
I was also getting nothing from the console initially.
After swapping white (TX) and green (RX) cable connections on the board, the serial console input/output is working fine. You may want to try the same thing.

And I can get into u-boot shell via serial console.

As far as we know, there is some issue on MAC os with 15000000 baud rate since it’s not standard baud rate. Can you confirm that baud rate works on MAC?

I don’t think we support fastboot, maybe @Lili can confirm that.

@byan - Thanks for the tip. I tried it out, but still nothing.

@jack - Well, unix screen terminal doesn’t complain when I specify 1500000 baud. I suppose it could be a FTDI driver level problem, but since it didn’t work on chromeos either which is linux based I’m starting to think perhaps the cable itself is the problem? But it did look to me like a familiar chipset in the adapter, I could be wrong.

Also fyi @jack u-boot does support fastboot mode, which thankfully I was able to boot directly in to via adb reboot fastboot since I couldn’t interact with the u-boot shell via terminal.