Can't boot new rockpi

I bought a rockpi. Made a SD debian-image and powered on
Nothing except green led.
Serial console says nothing
Monitor stays sleeping.
I returned it, got another card which is exactly the same
Power supplies tried; RaPi official power supply. Apple 65W charger. Samsung charger.
Various SD cards including SanDisk ultra and extreem
Wrote card with dd. Have made many RaPi bootable cards. Can mount and see pertitions and files on a linux system.
What happens when you power a card?
What happens if a monitor is plugged in?
What happens when SD card is plugged in (then power up)
I want to boot and run from NV m2 so SD card is to bootstrap the m2.

Any other suggestions


I would check if the serial console is connected correctly and whether its functioning.
With a working serial console, get output as soon as the board starts booting.

This likely wont work, the docs suggests 9V and above.

I’ll find a way to test the serial cable. It is an FDTI interface.
As far as I can tell the board never starts booting
I’ll try getting another PSU. I can’t find specs for apple charger. but I’d expect 65 W would be 32V at 2A. Can’t find ant info on SAMSUNG charger

Apple mac USB C charger is reported to work:

I dunno why its not working in your case.
There is a report of Rock Pi not booting with serial console attached and USB PD, try removing the serial console and see if it works.

using apple charger
serial console before power on and after power on
serial console says nothing (although the scratch of inserting the leads says a few random rubbish)
serial port echo’s when looped
minicom status confirms baud rate, par and stop bits.
This is 2nd board that is identical. Unpacked on and never off antistatic mat.

What happens powered on with and without SD card?

BTW I tried Tx and Rx both ways just in case

First many thanks for the help here. When it could be the card or the power supply or the SD card you get overwhelmed. For reasons I do not understand (yet) making the card with dd did NOT work but using etcher DID work…l
So I have a working card. Thanks all