Can't boot 2 out of the 3 Rock Pi X boards


I was wondering if anyone can help. I bought 3 Rock Pi X boards (I plan to get more if I get a cluster working). On the first one, I was able to get Ubuntu and then K3OS running without much issue. The other two don’t appear to power up. I have tried different power sources (2 types of usb c chargers and a raspberry pi poe board), all of them work with the good board and none work with the 2 bad boards.

I’m not sure why the two bad boards don’t work.


Could you provide info about the bios version, any problem or behavior with the bios? do you have the cable for serial communication with the board? Have you tried reflash the bios with the ch341a programmer?

I’ve not got the the ch341a or the ribbon adapter to connect the UART to. I suppose I could try getting that. The bios on the working one was V12_X64_20200832, but I upgraded it to the V12_X64_20200924. I would assume the others are the same, but as I haven’t booted them I couldn’t tell you.

it’s worth a try reflashing the bios, the bios could be corrupted, and since it is hard to the debug bios problems (dont’t know if it is possible with the serial console), it makes difficult to solve them. Have you measured your power supply to the board? It’s is stable and with sufficient amps?

I’m confident it is not a power issue. I’ve tried multiple usb c adapters, some of them for laptops and the raspberry pi poe adapter. The draw I measure seems sensible and they are working with what I would expect to be higher draw applications.

I had a problem with the Rock Pi X not posting. Radaxa and Seed Studio would not rake ut back, acted like I did something. I told them they wiuld get it bavk and its on its way. I got it replaced and ghey get ghe dead board. They will not kniw which one it is but thats not my problem Mission completed and I will NEVER buy anogher Radaxa product again.

I got the ch341a with the adapter for the right voltage. I tried it with the two problem boards and flashing it with the bios I suspected them to have, it said it was the same bios I was flashing, and made no difference. I tried the newer one, which also didn’t work. I checked it work with the good board, and it flashed it and booted with any issues.

I’m not sure what else I can do? My plan was to make a cluster with more of these, but I’m struggling to get three functioning to test them out.

This a tablet-like board, if you put power on the board (dim blue light led) it will not boot, you need to hold the power on button for a few seconds, then you get blue light led, then bright blue led, and only then the radxa logo and dim green light led only again.

Watch for this boot sequence, don’t use a third-party USB charger or poe adapter. Don’t use HDMI adapter. If you get stuck in the Blue LED you are in BIOS (most likely).

Not much info from you but if you can flash a new BIOS the board is booting, maybe you can print the serial output while booting?

  • fix info
    Dim blue = BIOS
    Bright blue = GRUB

I have this boot sequence, maybe this can help: