Camera format testing on Android 10

I ran a Camera Formats test with CTS Verifier 10_r3 on an Android 10 image (self build).

https://source.android.com/compatibility/cts/downloads

The Normal Preview looks fine, but the processed callback data is green all over, indicating that the data is probably not being acquired properly.

This is the same for both the NV21 and YU12.

Is there something wrong with the camera area on Android 10?

Camera in use:
https://www.waveshare.com/ov5648-5mp-usb-camera-a.htm

By the way, I passed all the Camera Orientation tests.
So the preview and the camera shooting itself seems to be fine.

I tested it again with the official Android 10 image and it’s getting the data right.
https://wiki.radxa.com/Rockpi4/downloads

Apparently there is a problem with the image I built.
I’ll check the procedure again.

Hi, radxa team

I’m having this problem when building from the public manifest, do you know what the problem is?

How do you compile it?

Hello,
okhiroyuki’s Image is my build image.
I executed build-rockpi-4c.sh.

Can you provide a test app?
Does this test require a professional camera?

test app is Camera Formats test with CTS Verifier 10_r3.

Camera in use:
https://www.waveshare.com/ov5648-5mp-usb-camera-a.htm

Maybe a USB camera can verify this.

OK, I will test it.

1 Like

Can you try the RaspberryPi Camera V2? Use the MIPI interface, I tested the camera and it worked. There are also problems with usb camera in our test. It may be that usb camera is not supported.

Since the RaspberryPi Camera V2 has no AF, we opted for a USB camera.
Can you guess which part of Android 10 is the problem?