Bricked? Power LED flashing dimly, can't enter boot mode


I just installed kali linux on my radxa zero using the SD card and then installed my compiled kernel (I tested this kernel last night and it worked well with kubuntu).

I proceeded to run u-boot-update to point to the new kernel I installed, then rebooted the board. This is the same procedure I followed when I installed my compiled kernel to kubuntu.

Now it doesn’t even power on, power LED blinks but very dimly and the board is not drawing any power (I’m using a USB-C cable that displays the power draw). I also can’t seem to enter boot mode.

Any advise on what could have gone wrong, or have I permanently bricked my Radxa Zero?

update: it just got worse, USB boot button essentially just fell out after trying to enter USB boot mode. had really good success last night with getting the waveshare 7.9 LCD to work, but it seems my luck turned for the worse today.

update: I wired up the serial port as a last ditch effort but couldn’t get any data. It was fairly obvious it wouldn’t work as the board doesn’t seem to power up normally, but I still tried anyway. Im happy to try other options if anyone else has any ideas.

Also, I would like a response from anyone from Radxa if there’s a warranty for these boards and if I can get a replacement. More than that though, I would like to know what went wrong, or if I did anything wrong so I can prevent it in the future. I can provide a detailed account of my setup and what I did, if it helps. Thanks!

Can You post photo of board? Anything happened to it just before that? Falling of elements usually means that there was some serious impact and something more is damaged than that button.

Hey @dominik thanks for the response. I’ve attached photos below. I’ve also uploaded a video that shows the power LED blinking. Note that i’ve dimmed the room just so the blinking LED can be captured. Its very dim and not noticeable if the room lights are turned on:

Some notes:

  • The board was already installed inside a custom case as per the photo. It’s secured using nylon screws, and is installed below the keyboard (also in the photos). The antenna, the USB C cables for the power and the hub, and the HDMI cable were also attached, and I’ve been using this setup for a few weeks so I know that all of the connections and peripherals were working well.
  • I didn’t install the OS to the eMMC because I was still experimenting with the different distros available. So the board boots via microsd card which makes switching between OSs easier.
  • I installed a fresh Kali distribution to the microsd, updated and upgraded via apt, and installed gnome-desktop. Once I had these working, I installed a new build of the kernel following the wiki instructions. To note, I’ve already tested this same kernel build on kubuntu some nights back, so I know that the kernel was working fine.
  • I then ran u-boot-update, but didn’t point to the new kernel yet. This would have been done at a later stage.
  • I rebooted the system, but was met only with a blank screen. I tried to powercycle several times but it didn’t help.
  • I disassembled my setup to see what was happening, and noticed that the power LED was not ON. I then removed the board to inspect closer, and try to boot it using my other monitor. I’ve also used different power supplies, different keyboards, and other peripherals, but with the same results.
  • Still no luck, board was still not booting, and when I looked closer, the power LED was blinking but it was blinking very dimly. It was also then that I saw that it wasn’t drawing any power.
  • I attempted to USB-boot several times, still no luck. The board wasn’t detected by my computer, and running confirms that the device isn’t found.
  • I attempted to USB-boot several more times, thinking maybe it’s an issue with the timing, but on the final attempt the USB-boot button already detached (note on the photo, i attempted to resolder the button, which obviously didn’t help)
  • As a last ditch effort, I soldered the headers to connect to my USB-to-Serial cable. As expected, there wasn’t any data received.

So in summary, it can’t be any physical impact that damaged the board. It got bricked while it was securely installed inside the case, which itself was just sitting on my desk. The button falling off was likely due to my multiple attempts at USB-booting, but it happened only after the the board stopped booting so it’s unrelated.

Do you have any other troubleshooting suggestions?


Did you operate the board without an antenna? I also operated my first Zero without an antenna. After a few days, the power LED was dim and the Zero was drawing an awful lot of power. I swapped him. I only operate my new Zeros with an antenna.

Hey @Albatros62, thanks for the insights! It’s useful to share, as there could be others in the community who are not using an external antenna (for reference, from what I understand zeros with unsoldered GPIOs need an external antenna).

In my case, I did use my zero without an antenna for maybe over a week without issue. I then installed it in the case with the antenna connected along with the other peripherals. It worked perfectly fine for a few weeks, and the antenna was definitely connected when the issue happened.

It could also be that it was just a coincidence. The Zero broke before the antenna arrived. It must have been the power supply. Feeding in via the pin strip did not bring any change either. A pity.

Possibly so, though I don’t really know enough to know whether or not connecting an antenna would matter (besides the low signal strength).

It would be good if someone from Radxa can give some pointers. I know things break, but some pointers from Radxa on what or what-not to do to prevent this from happening would be helpful for sure.