Boots with Radxa IO but doesn't boot on CM4IO

Hello,
I just received some Radxa CM3 modules. I was able to burn the image from https://wiki.radxa.com/Rock3/downloads and successfully boot using the radxa IO board. We then modified the /boot/uEnv.txt to use rk3566-radxa-cm3-rpi-cm4-io.dtb. and tried running the sd card on the CM4 IO. We get no sign of life except a red LED on the IO board. Additionally the CM3 boots on the radxa IO with this change also.

Our CM3 has EMMC, is that an issue with the RPI CM4 IO board?

Any help is appreciated

Any more info on this?

maybe you need the same hack https://wiki.radxa.com/Rock3/CM3/raspcm4io/getting_started#Power_on ?

Not an answer, i have the same problem as @dl-m10. Can anybody help? If i need the rock io board for the CM3 to work, where has the pi compatibility gone?

Not sure what @dl-m10 means but:

Radxa CM3 + IO board, have you installed the image to eMMC?

If yes, you should edit the /boot/uEnv.txt to use rk3566-radxa-cm3-rpi-cm4-io.dtb and save, power off the Radxa CM3 + IO board and unplug the CM3, put it on Raspberry Pi CM4 IO board and power on the CM4 IO board.

Better attach a serial console, the UART TX/RX is at 40P GPIO 2&4.

@jack I have not tried this yet, but if this fixes the problem, could you please add it to
Rock3/installusb-install-radxa-cm3-rpi-cm4-io - Radxa Wiki
Thanks for the reply.

Hi Jack,
We got the CM3 to boot off an SD card on the Radxa I/O board. We then modified the dtb to use the
RPI CM4 io board and we are getting 0 signs of life from the Radxa, no led blink, no serial, no boot. I need answers, this is for a production solution where we will be purchasing 1000+ units