Boot Rock Pi 4 B from eMMC


#1

Has anyone prepared eMMC so that Rock Pi 4 B would boot from it and work flawlessly?

I am looking for an instruction.


#2

It’s simple.
Just burn the image onto the eMMC.
Best to format it first with SD-Formatter. I burn with Win32DiskImager.
You’ve got the eMMC to sd adapter. Use that.
Not all sd-card readers can read/write with it. I’ve got many, about 50% don’t work.

Then it’s just plugging in the eMMC module and boot.
Whit what part are you having problems?
Which OS did you burn onto it? Can be that Armbian doesn’t work directly like that, I haven’t tried it yet.


#3

I’ve made exact copy of (fully working) SD card onto eMMC. SD card source is provided by Radxa OS image. Just used for some time and configured in such a way that it should be working (no changes especially for eMMC) - so that’s why I am surprised it does not work, just nothing shows up on HDMI screen.

I’ve used Ubuntu 18.04.1 LTS with kernel 4.4.154-59-rockchip-g5e70f14. The partitions are the same as on microSD card.

No SD-adapter has arrived. The only way to use eMMC I have is connected to Pi.


#4

Got it!

First, I’ve put original Radxa image to eMMC - it worked, Ubuntu was visible through HDMI. That meant the eMMC and start from it are ok.
Then I realised that the SD image written to eMMC should work. But taken other way: I’ve used the original image (just right after) and copied data from SD to eMMC using rsync with special options to leave folders and files permissions and attributes intact. The command is in other topic here. Just don’t mess up the folders.
This wasn’t working and acted as my last message here. So I realised that mostly system does not start when /etc/fstab is not written properly. By adding # to line with “mount boot partition” in fstab - it worked!

Now the system is on eMMC, no SD card is needed.