Boot of 3rd part image from SD-Nand

I have a RockPi S with 1GB memory onboard.
I tried to flash the buster official image and it works fine. I tried to flash Armbian and RockPi does not boot at all (same image is fine from SD-card).

What are the requirements of the image for booting from DS-NAND?

hmm… If I remember correctly, the miniloader(which loads uboot.img) in ROCK Pi S official image is a customized one. Do you have serial console for more low level output log?

@piter75 what miniloader does Armbian build use?

the problem with official image is their size, the remaining space is very limited.

With Armbian I have some more space for installing the tools I need

I think we should fix this issue with auto resize partitions. @Stephen @setq

1 Like

that would be great!

We are using a standard one - straight from Rockchip’s rkbin repo.
I did not have a NAND model at the time of initial bring-up and did not care that much :wink:
I will look into that and try to exchange it with Radxa’s custom one to allow NAND install.


great, I can help with testing if required

I’m with @Darmur. It would be great to have armbian in the NAND of our RockPIS, with the official distributions we have very little space left.

One advantage that RockPiS have is the incorporation of NAND memory in a reduced board, but with the official distributions I can hardly install anything extra.

1 Like

@Darmur @acoron the change seems :wink: pretty straightforward - I will test it over the weekend

1 Like

I have switched the miniloader for ROCK Pi S used in Armbian to Radxa’s one (with SD NAND support) with this PR.

Images with this feature are available from Armbian download area - version v20.05.6.

To use it one can boot with SD, run nand-sata-install, choose Install to eMMC and reboot.
The other option is to write an image directly to NAND with rkdeveloptool.


works great! thanks!

1 Like

I get this message on every boot

partition does not look resized

due to the little remaining space, I can’t even install armbian-config for resizing the partitions.
Is there a way for manually forcing the resize?

I managed to resize the partition following the steps reported here

With some more space I could install armbian-config

Resize must be done automatically at first boot. It worked well when I did testing.

root@rockpi-s:~# df
Filesystem     1K-blocks   Used Available Use% Mounted on
udev              246228      0    246228   0% /dev
tmpfs              49940   5388     44552  11% /run
/dev/mmcblk1p1    890312 655380    178132  79% /
tmpfs             249692      0    249692   0% /dev/shm
tmpfs               5120      0      5120   0% /run/lock
tmpfs             249692      0    249692   0% /sys/fs/cgroup
tmpfs             249692      4    249688   1% /tmp
/dev/zram0         49584   1932     44068   5% /var/log
tmpfs              49936      0     49936   0% /run/user/0

That’s why I suggested booting from SD and using nand-sata-install for installing to SD NAND as a first option :stuck_out_tongue:

There is still a bug in resize procedure and how it assesses the fact that rootfs has already been resized. It exhibits itself for very small media.
In current implementation 200MiB is reserved for spare area and this is almost 20% of the space available with 1GiB SD NAND. Then after resizing it treats file system as completely resized if it has at least 512MiB free space - which is never possible with 1GiB.

The review of the PR is pending and we will probably have it fixed soon.

Ahh, I already used that patch for making my test image :slight_smile:

1 Like

I tried that, following this procedure

  1. flash minimal image to SD-card
  2. boot from SD-card
  3. sudo apt install armbian-config
  4. launched armbian-config
  5. selected nand-sata-install

This is not working because required space on eMMC was not enough

I solved flashing the image directly on eMMC, resizing manually and then installing armbian-config.
I had to install the required packages first, dividing them in few groups, cleaning up (apt clean && apt autoclean && apt autoremove) and then install armbian-config

Trying to install armbian-config directly was failing because the space was not enough

You don’t need to install armbian-confi, just run nand-sata-install which is installed by default. This way it should go. Also wait for the update that fix made by Piter come to the image.

1 Like

Do not install armbian-config if you don’t need anything other than just nand-sata-install.
This command nand-sata-install is available directly from the command line even in minimal image :wink:
This will probably solve your free space issues…


Great, I’ll try that as soon as new image with fix will be released (please let me know when)