Board does not boot, missing 3.3V on the pin header

I have received a new 16GB board that does not boot even with the well-known working UGreen supply (LED changes from the blue color to green and back to blue only).
In addition I have checked the voltages that are accessible on the 2x20 pin header (5V and 3.3V). What is strange is that the 3.3V is always missing on this connector (for example on pin 1). Can it be that this board has another problem, is defective?


I would try to return the the Rock 5b as it does indeed seem defective. Just for fun I put my voltage meter on on pin 1 and 20 and indeed get 3.3. currently I have heatsink and fan So I am using 4 and 6 for the fan.

Del Mar

Can you try this steps:

I have already tried some of the points and an additional one:
1.) Tried to boot-up with all the extension cards removed (WIFI, NVME SD card) and pressed maskrom button -> no effect, no new USB device on PC’s with Linux (lsusb) and under Windows and under macOS.
2.) Bought a faster SD card -> no effect
3.) Used a dummy 12V USB C power supply -> no effect
4.) Based on the fact that there is absolutely no console output I have checked different USB to serial cables if there is a problem with the speed of the serial interface and if that is the reason why I see no output at all. -> I have tested it with an an RK3399 board which has a baud rate of 1500000, too. -> Result: Console output with the RK3399 board is fine, no output with the Rock 5B.

However when I look at the schematic as long as there is no 3.3V the board can not boot at all from the SD card because the SD card standard requests that reading from the SD card has to start in the 3.3V mode if the board does not require the special “LV” card type. And I have nowhere seen that the Rock 5B requires such a card.

Addendum: The micro SD card is powered with 3.3V only based on the schematic (page 26, rev 1.1), fixed 3.3V supply for the micro SD card.

There remains just one possible cause: The PMIC RK806-1 is not working as it should. Does somebody know if the chip is OTP programmed on the Rock 5B for power supply sequencing?- If not: I can try to rework the chip before I directly throw away the new not working board.

I checked all the output voltages of the RK806-1 buck converters in the meantime: There are all voltages OK besides the VCC_3V3_S3.

The RK8601-1 PMIC was reworked/ replaced with a new working one and the “dead on arrival” board is booting now. Thanks Radxa and Allnet China for the not existent customer service!