Audio jack and Nuvoton not working

The 3.5 audio jack does not work, and the Nuvoton SST shows a Code 10 error: STATUS_DEVICE_POWER_FAILURE.

I have aready tried without success:

  • Drivers from RockpiX 2020-09-04 driver archive
  • Drivers from Atomic Pi May 2019
  • Updating Win 10 to latest release (20H2, build 19042.610)
  • RockpiX and Atomic Pi drivers again under Win 10 20H2

I am beginning to suspect a hardware malfunction of the Nuvoton chip.

Any suggestions?

Check what the Device Manager says.

[yellow exclamation mark] Nuvoton SST Nau88L24 Codec Device

This device cannot start (Code 10)
STATUS_DEVICE_POWER_FAILURE

Can you install this utility and check if it works for you? It’s the codec configuration tool.

https://dl.radxa.com/rockpix/drivers/windows/NPCA120.7z

Thanks, Jack. Unfortunately it did not work, the 3.5 mmm audio jack is still dead and the device manager shows the same error code for the Nuvoton.
Is there any way to check if the hardware (Nuvoton chip) is actually working?

Immagine%202020-11-09%20224304

Does it work when you receive the board with the OEM Windows 10 image?

Nice question. The honest answer is that I don’t know.

What I know is that, after installing Windows 10 2004, I managed to resolve all the “yellow question marks” in device manager, so I am resonably certain that there was no warning for the Nuvoton, but I did not check whether the 3.5 mm audio jack was actually working or not (I only listened to HDMI audio through a TV set, and to a Bluetooth headset, both of which I think use the Intel codec).

Some days ago, still using Win 10 2004, I tried a headset with the audio jack, realized that it was not working, and spotted the Code 10 error in the device manager. Then I started the whole rigmarole, and eventually updated to Windows 10 20H2, to no avail.

So, the short answer is that (probably) the device manager Code 10 came up at some point, but wasn’t there from the beginnining.

Strange things happen… - I enabled the thermal sensor (TDS) in BIOS and, lo and behold, when Windows came up, there was no Nuvoton error in the device manager and the 3.5 mm audio jack worked flawlessly.

I just listened to some music, then I switched off the Rock Pi X, without touching anything. Next time I switched it on again, the audio jack no longer worked and the #$@&%! device manager Code 10 error reappeared!

So I did countless trials, cycling through [power on - change something / do nothing in the BIOS - look if the audio jack worked or not in Windows - power off].
Sometimes the audio jack worked, sometimes it didn’t, but I was not able to define a specific pattern, or a repeatable setup.

My provisional conclusions are:

  • The audio hardware looks OK.
  • After power-on, something happens that dictates whether or not Windows 10 will be able to start the Nuvoton device and to activate the 3.5 mm audio jack.

Now, if only we could understand what it is…

Try to flash the bios and with default setting, it should work. Can you check that? If with default bios setting, it works sometimes but not working other times, it might be hardware issue then. It just passes the QC when it’s working.

The audio was working. I did a restart and I resetted the BIOS to the default settings.
When Windows came up, the sound was still working.
I did several restarts, each time the sound went on working.
I did a shut down. When Windows came up the audio jack was no longer working and the Nuvoton codec had the usual STATUS_DEVICE_POWER_FAILURE erro Code 10.
So far, I haven’t been able to restore the sound system to working conditiion.

I would guess that the sound system is working, but there might be some problem related to voltage regulation.
After all, the device manager error message STATUS_DEVICE_POWER_FAILURE pointed in that direction from the very beginning.

By the way, I am powering the Rock Pi X with an Aukey 5V-20V 60W USB-C power supply, so there should not be any problems on that side.

Thanks for your continuing support.

I have the exact same problem.

I originally installed Windows 10 from the Media Creation Tool @ microsoft.com. I can get HDMI sound no problem. After a while, seemingly randomly, the speakers just started working. They worked all evening and night, but once I rebooted the Rock Pi X (left the USB power on the entire time) I lost that item from starting in the control panel.

I re-installed windows from the install.WIM that was provided in the radxa Wiki. This gave me the exact same error - but it has not once given me any speaker output.

For what it’s worth @Josh_Luthman, after my previous post (audio jack not working), I went back to BIOS, changed an apparently unrelated setting (TDS, thermal sensor, don’t even know if this setting is actually doing something), and the audio jack went back to work, obviously the Nuvoton error disappeared as well.
For the past 4 days it went on working, and even survived several power downs.
Who knows…

I spoke too soon…

I went into chipset south bridge and changed the sound, forget the exact option name, and now I’ve got this

Same here
STATUS_DEVICE_POWER_FAILURE

AND YES.
SOUND started working after changing TDS setting in BIOS

An idea that came to my mind while reading another thread: I don’t have the RTC battery (https://wiki.radxa.com/RockpiX/hardware/rtc).

Maybe the BIOS forgets something without the battery, and by changing other BIOS parameters the correct settings for the Nuvoton are temporarily restored?

May I ask @Josh_Luthman and @Zabaluyev if they have the RTC battery?

I do not. I have no RTC battery

I do not have an RTC battery. My settings seem to be saved, though.

I know that I’ve left the USB power plugged in, but I do not know if the BIOS settings will always persist through reboots/shutdown/power on/etc.

Where did you find the TDS settings???