Asking for Complete Step to Flash Debian into emmc on radxa zero

Hi everyone. i just got my radxa zero board today. i follow exactly like in this link but my board won’t boot with debian buster

https://wiki.radxa.com/Zero/install/eMMC

Thus i would like to ask help here what is the complete step to flash debian into emmc of the radxa board. it would be better if the guide is for windows OS since i’m using windows 10 OS. regards.

Hi Mikegyver,

A couple of questions for you.

1- Are you using this debian image?

2- Are you able to complete all the steps in the guide (install drivers for the board, connect board, erase eMMC, boot it in disk mode, see it as a drive in “This PC”, and then writing the image to it), and the board doesn’t boot? or did you encounter any issues while following the steps?

3- Are you using Ethcer to write the OS image to the board, or a different tool?

4- If you succesfully flashed the OS image and saw that the board does not boot, have you tried to check that the contents of the boot partition in the eMMC are readable by connecting the board to the win10 machine and configuring it as a USB storage device?

(Edited to fix numbering on the questions)

hi @ckrt.

  1. yes. i’m using the same image as you mentioned.

  2. yes. i’m able to complete all the step in the guide starting from install driver for the board on my PC, connect the board as USB disk, erase the emmc & flash the image on it as in the link https://wiki.radxa.com/Zero/install/eMMC

  3. Yes. i’m using Etcher to write the os into the emmc.

  4. yes. together here i attach the screenshot for whole step.

But still my board is in bootloop. any advice to solve it?

I’ve got the same problem.
Everything seems working as it should be, except nothing happens on booting.
I’ve tried with Debian Ubuntu Server, DietPi, even Android to boot from 8GB eMMC on Radxa Zero 2GB.
And still no luck.
I really want to have Linux working through eMMC.
What should I do to solve my problem?

Hi. What is the specific problem you encountered?

If you see bootloop with HDMI monitor, it may be due to a problem with the power supply. Try another power supply?

It was working when i used MicroSD instead of eMMC.

@akal See the steps outlined by @tinic here: https://forum.radxa.com/t/bricked-radxa-zero-invalid-partition-1/7401/5?u=jase

Thanks @jase, I have done that from windows.
The only thing that i don’t know is:
" Finally, after using Etcher to write the Debian image I ran the following to write the bootloader to eMMC:
sudo dd if=u-boot.bin of=/dev/sdx bs=512 seek=1 "

Where can i get u-boot.bin?

u-boot.bin is available here: https://dl.radxa.com/zero/images/loader/