Armbian rockpi hangs after a while

I am testing Armbian 21.08.1 Focal with Linux 5.10.60-rockchip64 and my boards are hanging (green LED still on dimly, blue flashing LED stops) after around 36+ hours. Power cycling get them going again. 1) Anybody have this issues and have a workaround ?
2) Can anyone skilled suggest which log file(s) to look at ?

Is it from official Armbian or Radxa image ? If it is Armbian official then it is better to check at armbian forum too.

can look at dmesg and journalctl

1 Like

I tried/am using Rock Pi S with slackware and debian, kernels 4.4 and 5.10 … 5.12. (but no Wifi/BT)

I consider kernel 4.4 solid. In my experience it never crashed, idle or loaded. But I think I didn’t put excessive load on it. However, it once died when using a 256 GB microSD, which was very slow and developed corruption after some time. One is used as a squid proxy (uptime 53 days), and one may get dns, dhcp, tftp and other simple tasks.

With kernel 5.10 to 5.12 (I don’t remember which one exactly) I had “crashes” when idle for 1-2 days. (running vnc server and basically nothing else) These were accompanied by kernel oopses in logs. With very slight load (xload or gkrellm displaying on the vnc server) these seemed to go away, and crashes become much more rare. (Still not solid) With more load (compiling Gentoo packages) crashes appeared again, even if the load was not excessive.

With kernel 5.13 from slarm64, it seems to have improved. However, I haven’t tested it completely idle or with heavy load - uptime 12 days now, running an NFS server and otherwise semi-idle. So 5.13 might be solid now.

Maybe you can try a kernel 5.13 from slarm64, or just test a slarm image?

About log files, I run rsyslog to pick it up from systemd-journal (on slarm64, it is just rsyslog), and send it to a syslog server. This way I found the oopses after idleness on 5.10-ish.