Armbian 22.05.03 on Rock Pi 4C+ very slow

I have installed armbian 22.05.03 jammy on my Pi4C+.
The network didn’t autodetect the eth0 to my local network. (I have a PC/Windows, Pine64-Linux, Beagle bone black - Linux).
When I use the automatic network setup, DHCP never gets an address.
When I assign a static IP, it minimally works, but there are a lot of dropped packets. Traffic is too slow to be usable.

Any suggestions will be appreciated.

Do you have heatsink or fan attached for 4C+?

There is nothing wrong with Armbian. Problems are expected if you try to use image that was not designed for your hardware.

Support was done only for 4C, + is has different components and is in the works - if you support development it will be few weeks sooner, if not, it can stay this for months. In the mean time you can study documentation and adjust HW parameters that any modern Linux OS will work as expected.

There is no official image for 4c+ for now, I am waiting for it, too.

please try following links:

No, but the board is not in an enclosure and in a cool room.

Thanks, I did not know the + was that different from the 4C. Not sure I can help with development, in the middle of a big coding project. Appreciate the feedback.

Thank you, I will try it soon.

Wow, great, seems good so far. USB works, ethernet works, haven’t tried the WiFi yet.
Just had to dig to find the default password rock:rock.

Thanks to all that are working on these Linux systems.

enable wifi just input following command in termnial.

  1. sudo nmcli r wifi on
  2. sudo nmcli dev wifi connect “your_wifi_SSID” password “your_wifi_password”
    and then after a while.
  3. sudo ifconfig
    you will see the wlan0’s profile on screen, and have fun.