Anyone tried the new Collabora image?

Download here https://col.la/rockpi4bimg

Or

git clone https://gitlab.collabora.com/rockpi/rockpi4
cd rockpi4
docker run --rm --interactive --tty --device /dev/kvm --workdir /recipes --mount "type=bind,source=$(pwd),destination=/recipes" --security-opt label=disable godebos/debos --scratchsize=8G rockpi4.yml

You can login with Debian as username and password to a Weston session from which you should install KDE Plasma 5 or GNOME depending on your preference.

Weston is a bit pants but you might want to do a sudo tasksel select kde plasma.
In /etc/netplan change the renderer to NetworkManager and delete the usual /etc/network/interfaces.d file
Also dunno why they don’t theme sddm with breeze as everything else is.
sudo apt-get install sddm-theme-breeze
reboot

[Edit] yeah I did and it doesn’t boot :slight_smile:

I also tried it and also didn’t boot.
Didn’t want to investigate further.

I am going to give the compile a go as Collabora are like Panfrost and strange we should get an image that doesn’t as why offer it unless that was just the cnx guy.
At least I know how to run the git as @jack posted the repo and I have been scratching my head on what runs it.

I dropped ubuntu!!! and installed debian as expecting it being debian based on my PC.
Buster is looking quite good with kde-plasma and think the majaro guys have converted me.

I was playing earlier with my Rockpro64 with auyfans buster and 5.3-rc4 where I compled drm & mesa and was playing supertuxkart 1080p extremely smoothly, shit game :slight_smile: but i dont really play games.

All my tasks perform better on Ubuntu. Buster did improve a lot compared to Stretch. But it’s still not as fast as Bionic. And Ubuntu Disco is even faster…

Supertuxkart is an awesome game.

Let us know if it works. I’m going to try to install panfrost on Armbian.

Oh my life my old i7 and dodgy bios wasn’t turning on intel virt even though set.
So I reset the bios (jumper job) set things back up again.
I don’t know what happens with this z77 board but gigabyte are pants as I have had asus from the same period and they are amazing as they just work.
Windows lost its efi part or whatever happens as my duel boot system does this again and again reset the mobo and it will not boot but debian fine.
So now after managing to get virt so the above will run and compile I can safely say nope it makes the same image as they have.
I emailed the creator saying hey update from 5.3-rc1 to 5.3-rc4 as we are all downloading your image and repo to find its not working.
5.3-rc1 was a stinker for some.

So anyway I wiped the lot my blingdows is back and think actually I am going debian a bit, loving kde plasma via debian as the theme is not as gut wretching as it is on ubuntu.
But its build scripts just like the rockpi4 build toolchains favours a ubuntu host, a lot of the painfrost activities favour debian host tool chain.
I would prob run all 4 with windows, debian, ubuntu and manjaro (arch is so cool for the latest and greatest) if it wasn’t for my fickle bios, I am cursing at replacing 2.

Panfrost runs SuperTuxKart great but dunno about SuperTuxKart :slight_smile:

The actual build script above when you don’t have dodgy bios like mine is just so simple you just bang in the above and instant image but its stuck on 5.3-rc1 and you can not browse there directories so can not simply change it.

If you do play games then presuming all the quake arena to tux level games will run extremely well with painfrost as I have now christened it.
OpenCL should also be interesting but don’t know what stage that is at as think they are still completely the full egl3 api even though it looks like its there.

You can do the same with the manjaro images and then just follow https://www.96boards.org/blog/panfrost-rock960/
substitute the buntu to arch.

1 Like

The good news does not stop here, as Collabora also worked a V4L2 driver for the Hantro G1 video codec used in RK3288 and RK3399 SoC’s, which will also hardware-accelerated video playback in mainline Linux. More details about the V4L2 drivers will be shared in a future post on Collabora.

The real highlight of the article. :boom:

Yeah that really perked my interest as well as video acceleration was extremely similar to the proprietary driver problems where drivers exist but a unified solution doesn’t.
I killed my computer for that!!! :slight_smile:

Hi
Do you happen to have logs from the serial console? I’ve noticed that the image doesn’t boot every now and then for me due to a emmc timeout issue.

Never got that far with me but using sd card. Actually forgot what the error was now but didn’t look like something a u-boot env change could fix.

The build script is rather good thought as @jack posting when I was requesting we should have a mainline BSP.
It would be great if Radxa did, but you get run local with gitlab-runner

curl -L https://packages.gitlab.com/install/repositories/runner/gitlab-runner/script.deb.sh | sudo bash
That script for some reason froze on me so just pasted the contents in a file https://packages.gitlab.com/install/repositories/runner/gitlab-runner/script.deb.sh chmod a+x and sudo ./$file

sudo apt-get install gitlab-runner

From the the repo collection https://gitlab.collabora.com/rockpi
If we wanted the kernel git clone https://gitlab.collabora.com/rockpi/linux
cd linux and

gitlab-runner exec docker build

But obviously don’t really want to change from how they have 5.3-rc1 as hopefully v4l2 magic is in there.

But you could run your own and just change the yaml for the kernel.deb you just made.

PS

USAGE:
   gitlab-runner [global options] command [command options] [arguments...]

VERSION:
   1.1.0~beta.135.g24365ee (24365ee)

AUTHOR(S):
   Kamil Trzciński <ayufan@ayufan.eu> 

:slight_smile:

I’ve gotten it to work on Armbian Bionic.
Great to see this finally working. Thanks to Salvador Liebana.

Videos are comming of Linux gaming on the Rock Pi 4B.
Cheers.

2 Likes

It’d be a great help if someone could post a full bootlog from serial for the Collabora image.

You can find the boot log here:

https://pastebin.com/X3h3AwTt

Thanks jack!

I see that the board boots, but fails to start weston.

[FAILED] Failed to start Weston, a …mpositor, as a system service.
See 'systemctl status weston.service' for details.

Could you paste the output of:

systemctl status weston.service

I’ve made a tutorial on how to build an Armbian image with Panfrost.

2 Likes

Panfrost is no problem (aka) mesa and RC2 is released in a few days.
Its like what @tonyunreal mentioned its the v4l2 additions in that image that we have been trying to grab.

Dunno if you guys have a later image or I do but last time I tested last week that image never booted.