Android TV not booting


I wanted to try the Android TV image today on my Rock Pi 4 B 4G (on emmc) and after the “erasing”-screen (approx 3 sec) and the Rockchip-kernel-screen (approx 1 sec) the screen goes dark and will not come up again (waited hours). Linux will boot fine though.

I would very much appreciate some help, thank you!


From what I guess, it maybe the power adapter issue. The first time android booting needs more power than Linux booting. What adapter are you using?

Can you also try the “normal” Android image?

Thank you for your answer!

For power supply I am using a and tried both the QC ports and the so called “IQ” ports.

The “normal” Android image seems to be working, though I did not test it extensively, but with that image youtube-videos do not start playing neither in the youtube app, nor in firefox.

If you are interested in fixing the problem I can continue to try and provide information. Please send me what information you need.

Otherwise I will be trying to get the linux image running better, as I did not get it to play hardware accelerated video in browser yet (for another topic).

The power adapter should be ok, remember always use the QC ports for ROCK Pi 4. The normal Android image works with the Raspberry Pi display, which has 800x480 resolution, youtube won’t work on such low resolution. Could you try the Android TV image again? Maybe on microSD card? We don’t have issue here with microSD card or eMMC module.

If you have the USB to TTL debug cable, you can send us the booting log. But I guess not everyone has it. Refer:

I faced the same Problem. Anker Power Port doesn’t seem to work. I replaced it with a MacBook USB PD and Android TV OS boots. I also tried using a Chotech QC 3.0 Adapter and I was able to boot into Android TV OS.
Only issue with the Android TV OS is the missing DRM libraries due to which contents like Amazon Prime Video and Netflix don’t seem to stream.

1 Like

We will check the DRM issue.