Android image building problem

I am building the image for Radxa Zero according to the guide,something went wrong:
make: Entering directory ‘/home/radxa/zero-android9/out/target/product/faraday/obj/KERNEL_OBJ’

WARNING: Symbol version dump ./Module.symvers
is missing; modules will have no dependencies and modversions.

LD /home/radxa/zero-android9/out/target/product/faraday/obj/bifrost/kernel/drivers/gpu/arm/midgard/built-in.o
CC [M] /home/radxa/zero-android9/out/target/product/faraday/obj/bifrost/kernel/drivers/gpu/arm/midgard/mali_kbase_device.o
In file included from /home/radxa/zero-android9/common/include/linux/ktime.h:25:0,
from /home/radxa/zero-android9/common/include/linux/rcupdate.h:47,
from /home/radxa/zero-android9/common/include/linux/rculist.h:10,
from /home/radxa/zero-android9/common/include/linux/dcache.h:6,
from /home/radxa/zero-android9/common/include/linux/fs.h:7,
from /home/radxa/zero-android9/common/include/linux/debugfs.h:18,
from /home/radxa/zero-android9/out/target/product/faraday/obj/bifrost/kernel/drivers/gpu/arm/midgard/mali_kbase_device.c:29:
/home/radxa/zero-android9/common/include/linux/jiffies.h:11:33: fatal error: generated/timeconst.h: No such file or directory
#include <generated/timeconst.h>
compilation terminated.
make[3]: *** [/home/radxa/zero-android9/common/scripts/ /home/radxa/zero-android9/out/target/product/faraday/obj/bifrost/kernel/drivers/gpu/arm/midgard/mali_kbase_device.o] Error 1
make[2]: *** [/home/radxa/zero-android9/common/Makefile:1623: module/home/radxa/zero-android9/out/target/product/faraday/obj/bifrost/kernel/drivers/gpu/arm/midgard] Error 2
make[1]: *** [Makefile:152: sub-make] Error 2
make: *** [Makefile:24: __sub-make] Error 2
make: Leaving directory ‘/home/radxa/zero-android9/out/target/product/faraday/obj/KERNEL_OBJ’
[ 0% 19/60825] //external/protobuf:ap…piler/cpp/ [linux_glibc]
ninja: build stopped: subcommand failed.
15:41:17 ninja failed with: exit status 1

failed to build some targets (01:33 (mm:ss))

How do I fix this?

Greetings. I have exactly the same problem. I can’t find a solution to this problem on the internet. Did you manage to solve it?

If you want to work with Android, I personally recommend Lineage OS:

If you try it, let me know if it worked

Greetings. Thanks for the advice. However, my boss decided to use AOSP. By the way, I have solved the problem that is discussed in this topic.

Oh, great! Good to know that you solved the problem.
Can you share your solution? It might help @momo or someone else with the same problem

It’s very funny actually. It was necessary to immediately make “make clean” in the root directory of project. I have this /home/user/zero-android9. I did not do this immediately after syncing the repository.