Android 10 official image on 4C, there's a way to gain root?

Hi, i’m installing android q using the guide from radxa, so far, i’ve been able to boot from nvme using the SPI without problems, but i wasn’t able to gain root (besides the adb access). I’ve dumped the boot partition using dd and patching it with magisk, but i can’t write it vía fastboot because the bootloader seems to be locked, and there’s no OEM unlock option in developer options. I’ve already tried booting with linux, and overwriting the partition with dd, but then the 4C won’t boot again, i must be missing something about GPT partitions. fastboot oem unlock, fastboot flashing unlock, and fastboot flashing critical_unlock won’t work here. I’m trying to make an upgradeable car head unit, but i’d like to unlock root to allow further modification. Making it short, does anyone know how to root this thing? Or i must build the sources from the ground up?


Have you tried my pre-rooted Android 10 firmware?

You can flash the patched boot.img from Developer Settings but the firmware has to include a build setting to enable it(only enabled for ‘box’ builds, not ‘tablet’ builds radxa is currently doing).
Only a single setting has to be changed to ‘tablet’ instead of ‘box’ and firmware can still be build as ‘tablet’ and it should work.

(Property just has to change to ture instead of false)

1 Like

Thanks for the reply mo123, i’ve only seen your androidtv rom based on pie, if there’s a rom of android 10 pre-rooted and compatible with my 4C i’d be glad to try it.