Android 10 (HDMI 4K) Official Image does not leave the Android logo

Hi guys, I have a problem, I have a ROCK PI 4 PLUS Model B v1.72, and I can’t boot Android 10, I did it using 2 different MicroSD cards, I created the OS image with different programs and nothing, when I turn on the device with the card appears the ANDROID screen logo with an animation, but nothing happens, it remains on this screen infinitely, I left it for hours and nothing happens.
Any suggestions? The official android 9 worked but the 10 didn’t do it the same way.
Taking advantage, I tried to install the official version also from android 7:

  • Android 7 (DSI 480P)
  • Android 7 (4K HDMI)

Here nothing happens, no image appears on the monitor, everything is without a signal and only a green light is on, it’s as if you weren’t reading the card.
Remembering that the key is set at H on the board.
Thank you all.

me too.
tried two images already:
https://github.com/radxa/manifests/releases/download/1.0.3/ROCKPI-4AB-2020-10-15-11-14-gpt.zip
https://github.com/radxa/manifests/releases/download/Rock-android10-20210916_1117/ROCKPI-4AB-2021-09-16-11-17-gpt.zip

Hi my friend, I can’t at all install android 10 for rock pi 4 model B, no matter what I do, nothing works.
You got it ? or still nothing?
Do you have any idea how we can install this 10?
Thanks for answering, big hug.