Aml-flash-tool does not work

sudo ~/anaconda3/bin/ ./bootloader.img
that worked. lsusb now shows a different device: Bus 001 Device 009: ID 18d1:0d02 Google Inc. Celkon A88
adb devices shows nothing in the list
The 1st time I did this I saw no adb devices so I rebooted into a skeleton android system. I clicked the build# in about several times but then I still could not access developer mode settings (not allowed for this user)
Used a couple of different img file to erase emmc
followed instructions from this link to define adb device using #'s from lsusb will not run. woops. This time it did. The instructions do not specify wether to reboot or not. This time I did not and followed the first command after 30 sec delay with
lsusb # Bus 001 Device 010: ID 18d1:4e40 Google Inc. Nexus 7 (fastboot)
adb devices # 1234567890 device
I can boot into android again but I now have a much more complete os to work with. However,I still cannot get into developer options(not allowed for this user).

aml-flash-too is not working with lineage os images. I have tried with the stock image from radxa and a couple of the nightly builds. the flash tool just says no device found. I tried from from burn mode and from a booted os.
I can boot via adb reboot recovery and get to the recovery menu but adb sideload does not work either. I consistently get error 21, failed signature check. Maybe I should go back and flash android 9 again and watch more carefully for failure messages. Maybe it did not install completely either. Is there a routine for scanning memory and blocking out bad blocks?
there seem to be other paths to loading the image that I have not tried yet. I am gonna go look.
Tried adb reboot fastboot. Rebooted to logo and hung. adb devices = nothing
I should have tried aml-flash-tool again.