ADB over USB is not working in Android


i bought Rock PI 4A V1.4 for testing my GPU/A73 accelerated algorithms. Main target os is Android. I planned to use USB (ADB) as main communication channel, but got message:

[ 13.215681] read descriptors
[ 13.215782] read strings
[ 13.218996] dwc3 fe800000.dwc3: failed to enable ep0out

Image i used: rockpi-4b-nougat-20181221_1453_877b95b-gpt

Is there any Android image i can use where USB ADB is working fine?

thank you

Did you read and follow the Radxa ADB instructions?

I haven’t tried these steps yet, but a hunch tells me, try a USB Male A to Male A cable if you’ve had problems with a USB A to USB C cable so far. If that doesn’t help, please be patient until the weekend is over, then you can be helped.

I saw this, but its does not make sense now: HostPC do not see USB connection from RockPi4 board. As i mentioned before - if you see this message dwc3 fe800000.dwc3: failed to enable ep0out - means OTG cannot start.

Switch the OTG switch to D mode. Boot with USB A to A cable connected. We always use adb for debugging under Android. It should work.

Thank you for hint, but unfortunately this is not working.

Any other way?

Can you burn firmware through this port?

OTG switch to D/H mode.

When it switch to L/H mode. I got the same error message as you.

I tried this way. No activity. i’m using USBview to see if USB device detected in a system.

I will try this again on Monday.

Hello guys,

I followed this link :
But my rock chip is not detected by the computer. I’ve installed Android TV 9
Anyone got this problem ?


Ok I think a reboot of my computer fixed my problem

In my case - it works fine now. Fault was in switch. Need to change switch before booting.