ADATA M.2 XPG8200Pro

I want to use this SSD and, oh wonder, it doesn’t work. I tried:

  • Kernelupdate
  • lsblk
  • lspci

Nothing…
Kernel is 4.4.154-83. Does anybody know about this?

sudo dmesg | grep -E “pcie”
says Nothing… Maybe is PCIe not working?

Solution:
Turn off, wait, disconnect power
-> Turn on

Actually don’t use ssh use the console not saying it will work but dmesg | grep pci will show something.
sudo apt-get install pciutils as lspci should detect something, might be you need to do the pcie gen2 edit but wondering if you might be like me and its just pure chance on each boot due to some sort of timing.
I just had it work 3 times on a trot and now its gone again by just power on and then shutdown.

Is yours constantly intermittent if it boots with pcie? Worked 4 times as just tried again but its pure random with absolutely no change but shutdown and boot.

when it works sudo apt-get install iozone3

Auto Mode
        Include fsync in write timing
        O_DIRECT feature enabled
        File size set to 81920 kB
        Record Size 4 kB
        Command line used: iozone -a -e -I -i 0 -i 1 -i 2 -s 80M -r 4k
        Output is in kBytes/sec
        Time Resolution = 0.000001 seconds.
        Processor cache size set to 1024 kBytes.
        Processor cache line size set to 32 bytes.
        File stride size set to 17 * record size.
                                                              random    random     bkwd    record    stride
              kB  reclen    write  rewrite    read    reread    read     write     read   rewrite      read   fwrite frewrite    fread  freread
           81920       4    28607    34861    39915    40103    16139    30980

Try

lspci -vv | grep -E 'PCI bridge|LnkCap'

instead of sudo dmesg | grep -E “pcie”

If you take original RADXA image and run suggested command, you should get something this:

$ lspci -vv | grep -E 'PCI bridge|LnkCap'
00:00.0 PCI bridge: Fuzhou Rockchip Electronics Co., Ltd Device 0100 (prog-if 00 [Normal decode])
$ uname -a
Linux rockpi4 4.4.154-59-rockchip-g5e70f14 #4 SMP Fri Dec 14 20:55:41 CST 2018 aarch64 aarch64 aarch64 GNU/Linux
rock@rockpi4:~$ lspci -vv | grep -E 'PCI bridge|LnkCap'
00:00.0 PCI bridge: Fuzhou Rockchip Electronics Co., Ltd Device 0100 (prog-if 00 [Normal decode])
rock@rockpi4:~

after updating kernel and bootloader you should get the config file in boot folder in which you can enable pcie gen2, reboot, then you should get this:

$ lspci -vv | grep -E 'PCI bridge|LnkCap'
00:00.0 PCI bridge: Fuzhou Rockchip Electronics Co., Ltd Device 0100 (prog-if 00 [Normal decode])
                LnkCap: Port #0, Speed 2.5GT/s, Width x4, ASPM L1, Exit Latency L0s <256ns, L1 <8us
                LnkCap: Port #0, Speed 8GT/s, Width x4, ASPM L1, Exit Latency L0s unlimited, L1 <64us

If you do not get those values, either your disk is not compatible or you did not install properly m2 extended board or your m2 is not compatible.

What I clearly see is that mention m2 sidk is Solid State Drive PCIe Gen3x4. Maybe @RADXA could help, but probably addressing ADATA for providing a firmaware to fix (if fixable) backward compatibility (if thats the issue). However, can you ensure that this M2 runs on some other non Gen3/4 controller?

Better buy cheap m2 disk with read speads under 2000 and write speed under 2000, but both should be over 1000, because M2’s which are meant to run with 3500, that is waste of money and m2 itself if you run it only with max 1000-1500 on rock, its even less than 50% meaning that you lose to max. speed more than 50% making it actually a nonsense to use it in rockpi4, despite RADXA recommending it.

I got Samsung EVO Pro 970 which actually performs in the same way which my old notebooks m2, evo has maybe 100-200Mb advance on copying big files, but in real world it is as fast as my old where I could get 4 of them for the same price of EVO Pro. This would be as example one of such disks which you can find also used for really, really little money: KingSpec 128GB M.2 NVMe not found Debian+Ubuntu (I mean MZVLW256HEHP disk from which i posted benchmarks)

What I did is as first, I replaced old disk in Notebook with Samsung EVO 970 and put the old M2 into rock. Now the result is that Samsung EVO 970 Pro is a little bit more than 2x times faster in notebook than the old disk was. On rock, Samsung EVO 970 beats it a little bit on read speed, however, this is nothing I would really notice that strong as I do Samsungs 970 performance in my notebook.

@DAASSI

Try to update to the latest u-boot and check if it works.

sudo apt-get install rockpi4b-rk-u-boot-latest
sudo  /usr/local/sbin/rockpi4b_upgrade_bootloader.sh

It works at the Moment. Thanks for all the help :slight_smile: