4B+ failing to boot off EMMC or microSD - power LED on, two regular blinks on status


I’ve been running a Rock 4B+ (the OP1 version) with 4GB of RAM and 32GB onboard EMMC (v1.73 hardware) for a long while with no problems, but after trying to manually upgrade a running system to a newer kernel it failed to come back up on reboot, instead repeating just two short flashes on the status LED over and over with no output to HDMI.

I can get the device to work in maskrom mode perfectly reliably and load the rk3399_loader_spinor_v1.20.126.bin boot loader. I’ve tried overwriting the entire EMMC with several of the official images as well as wiping just the SPI with a 4MB zeroed image and the rkdeveloptool ef command. The various flashing operations reliably complete with no error messages, but I cannot get the device to boot either off EMMC or even microSD - after any and all attempts I just keep getting the status LED double flash and nothing else.

OS images I’ve tried:

  • Armbian Bullseye (upstream “minimal” image, flashed directly to EMMC via OTG)
  • Armbian Bullseye (upstream “cli” image, microSD)
  • Armbian Jammy (Radxa image, microSD)
  • Armbian Bullseye (Radxa desktop image, microSD)

I’ve also tried repeatedly to write the rockpi4b-uboot-trust-spi_2017.09-2697-ge41695afe3_20201219.img boot loader to SPI - again completing successfully every time but with no change to the boot failure.

The Rock4 was one of the heavy lifters on workloads for my home lab Kubernetes cluster so it being out of commission is a bit of a bother - any idea what might be going on here and how I could diagnose or fix the problem?

I think I have similar issues.
I used my 4B+ as an android device for a while. Then I tried to flash the latest armbian image through OTG, The blue status LED blinks quickly 2 beats and then repeat…
I have erased my SPI flash completely, replaced with rk3399_loader_v1.27.126.bin then flashed in the image again. Still no luck.
However I did get the Radxa image (debian version 202303 release) to work. You can try that or an older working armbian image if you just want it to boot.

I checked the serial console and it seems the issue is with HDMI output. I can log in and set up user etc. in serial console. The error message is then

root@rockpi-4b:~# [ 633.211385] hdmi-audio-codec hdmi-audio-codec.5.auto: Only one simultaneous stream supported!
[ 633.212145] hdmi-audio-codec hdmi-audio-codec.5.auto: ASoC: error at snd_soc_dai_startup on i2s-hifi: -22
[ 633.212986] ff8a0000.i2s-i2s-hifi: ASoC: error at __soc_pcm_open on ff8a0000.i2s-i2s-hifi: -22
[ 639.440718] rockchip-pinctrl pinctrl: pin gpio3-29 already requested by leds; cannot claim for ff880000.i2s
[ 639.441636] rockchip-pinctrl pinctrl: pin-125 (ff880000.i2s) status -22
[ 639.442248] rockchip-pinctrl pinctrl: could not request pin 125 (gpio3-29) from group i2s0-8ch-bus-bclk-off on device rockchip-pinctrl
[ 639.443344] rockchip-i2s ff880000.i2s: Error applying setting, reverse things back
[ 639.444084] rockchip-i2s ff880000.i2s: bclk disable failed -22