[230428] Beta System Update for ROCK 4 family

Greetings. Today we released the initial system for ROCK 5A. Since we use the same kernel for ROCK 4 and ROCK 5, we also updated the Beta system for ROCK 4. You can find how we categorize an image as Beta in the link above.

This update is mainly to provide working Ubuntu images for ROCK 4 family. However, Ubuntu is still not supported officially, as it currently lacks many important hardware enablement packages from Rockchip.

You can read the change log in ROCK 5A’s release notice.


ROCK 4A: 20230427-1720

ROCK 4A+: 20230427-1720

ROCK 4B: 20230427-1720

ROCK 4B+: 20230427-1720

ROCK 4C: 20230427-1720

ROCK 4C+: 20230427-1720

ROCK 4SE: 20230427-1720

More build variants can be found at radxa-build.

Kernel version: 5.10.110-6


Hi, C+ link here is not working; could someone please check?

An extra “i” was inserted as “/rocki” in the link posted, here is the actual:

Thanks Bubba, well spotted, small typo in the link! Without the “i” I found the right place.

I copied the unpacked image using dd to an emmc card. The image does not boot. The blue led comes on after about a minute though.

I tried the Debian Bullseye KDE b57 version. On the emmc card I can see 16M free space, a 16M Fat32 partition labelled “config” with “msftdata” flag. There are two files on this partition: “before.txt” and “after.txt”. The third partition takes all the rest of the space of the card, has a label “rootfs” and two flags, “boot, esp”.

Do I need to do any other trickery to turn this on?

1 Like

I have not downloaded and attempted yet myself.
One thing, my main OS is Debian, and I do not unpack. I just right click the downloaded file and burn to a micro-sd with Disk Image Writer. I may try this image later as time allows.
Perhaps someone else can enlighten us.

Just to clarify, by unpacking I meant getting the .img file out of the .xz file. I will also give a go with some other images here (xfce Debian or Ubuntu) to see if those turn on.

I copied the image to emmc on the Rock board itself, booted into some recent Armbian. I checked the dmesg and saw some emmc related errors. Eventually I managed to copy without errors, and the KDE Debian now boots, although the booting takes unusually long with the screen being black.
Nonetheless, the system is running smooth once booted. I only had a quick look so far, but first impressions are very good. Video acceleration is working in Chromium, although Youtube is throttling to 480p max; other websites allow and run 1080p fine. Some addons may fix Youtube. The distro’s built-in media player also plays 1080p fine, occasionally I saw some very small artifacts. I use only some makeshift cooling on the Rockchip for now, adding a larger sink that may help if this was due to overheating.

So overall this is some good stuff :slight_smile:

1 Like

Thanks. We are just back from holiday. I have fixed the broken link.

We observed that for all our products YouTube no longer provides resolution greater than 720p.

I just remembered a funny thing. When I switched from an XFCE image to kde, the “other” hdmi port became the active display.

Thanks Yuntian, for the clarity and update.

I have build a kali linux for the rock 4se with a kali kernel version 6.1.0 and it works great. I have no other radxa boards but for this one a docker image will be uploaded today 2023-05-07,


and SD-CARD image you can download @ https://github.com/byte4RR4Y/rock-4se-kali

A build with fixed zsh corruption and automatic resize root-filesystem IS ALREADY uploaded. I hope you you enjoy it and report all the issues. Your byte4rr4y…


i will generate a new kali linux build because this one won’t boot if you update the kernel, you should use ‘sudo apt-get upgrade -y’ instead of -sudo apt upgrade -y’ to avoid updating the kernel

1 Like