[230315] System Release Notice for ROCK 4 family

Sorry Igor for triggering You again, I didn’t wanted to point out any armbian bugs or inconsistencies, we talked here about unclear armbian part, not armbian itself.
I don’t blame You for this and don’t demand anything to be fixed as You always wish. But, nevermind, the whole point of that sentence is that armbian links here are just misleading and whole that stuff is confusing, maybe even incorrect for ROCK 4B+ that I have.

That was not a point, but example of project maintained clearly with accurate information on every single line. I’m sure that even single developer can use best practices with releases.
For now there are just tons of images and automatically created texts that are misleading, broken&untested images and all that will not help both users to understand what they are downloading and radxa to receive good feedback, bug reports etc.

Let me clarify that once again - the whole point of that reply is that this release system lack important information, builds too much with no good indication what it is, what is fixed/changed, what to expect. Hopefully will be improved :slight_smile:

CSI camera (raspberry pi cameras) still not working for me. With gstreamer I get a blurred image. Can’t get it to work with ffmpeg …
Is it possible to have a simple how to on how to record using ffmpeg?
I have been waiting for 2 years for this to work …
I am using rock poi 4b+

  • no dpkg reconfigure keyboard
  • no wifi connection because of error setting hardware address
  • rsetup is the worst setup-tool i’ve ever used (compared to raspi-config or armbian-config)
  • and everything dominik said 8d ago

Those images are unusable for me.

When armbian is developing images for rock-pi, why does radxa not colaborate with the devs there to get “best out of both”?

So what are my options using the 4b+ as server for home automation (no gui needed)?

Is there anyone listening who is using 4b+ not only for “fiddling around with linux and SBC”, but for real usage as a reliable linux system e.g. home assistant, fhem, iobroker, grafana, influxdb, node-red or else?


And who does not allow you to use the ext2 system for the boot partition?

Tested a little. No hdmi sound. Chromium in YouTube 480 max. Can’t bring up the onboard keyboard at startup … and in general KDE is shit :wink:

I’ve installed the ‘rock-4se_debian_bullseye_cli_b33.img.xz’, downloaded from h.ttps://github.com/radxa-build/rock-4se/releases/tag/20230312-1521, image in a rock 4 SE card, and the first steps of connectivity and configuration ssh,timezone,wifi all good, but when i try to configure the APT i am having problems.

I performed the steps as mentioned in this wiki:
Guide of Radxa APT(h.ttps://wiki.radxa.com/Rockpi4/radxa-apt#Introduction) and on the github page GitHub(h.ttps://github.com/radxa/apt).

After setting up the DISTRO

~$ export DISTRO=bullseye-stable

I also tried other DITROs like stretch-testing

~$ echo “deb http://apt.radxa.com/$DISTRO/ ${DISTRO%-*} main” | sudo tee -a /etc/apt/sources.list.d/apt-radxa-com.list
~$ wget -O - apt.radxa.com/$DISTRO/public.key | sudo apt-key add -

I get the error

Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
gpg: error running ‘/usr/bin/gpg-agent’: probably not installed
gpg: failed to start agent ‘/usr/bin/gpg-agent’: Configuration error
gpg: can’t connect to the agent: Configuration error

In a previous version I used the image downloaded from this link :h.ttps://github.com/radxa/debos-radxa/releases/download/20221109-1007/rockpi-4b-ubuntu-focal-server-arm64-20221109- 1331-gpt.img.xz, I didn’t get this error. There are a few more steps that need to be taken before APT can be configured in this new version

The documents are outdated. The system is already set up out-of-the-box.

New documents will be hosted on a new site.

Thanks for all the hard work! I have a question about the rbuild. When I run rbuild, is there a way to specify a tag to use for the build?

There is currently no tag for rbuild. However, each image stores the rbuild commit it was built with in /etc/radxa_image_fingerprint.

If you want to reproduce a released image, please refer to this page. Normal users should just use the latest system, and specifically recreating an older release makes little sense for them.

1 Like

Were we can find this new site?

i did find it simple Radxa.com

Ffmpeg does not work well with rock based boards. I had the same problems. You have to learn gatreamer.

After 4 years the Rock Pi 4c plus still does not have a Debian release that has wifi included. Evidently your design team isn’t aware of the fact that most users use wifi not a direct connection. When attempting to activate wifi the password isn’t accepted by the kwallet. This prevents wifi from being active. Question is why hasn’t this bug been addressed after 4 years?

Erm, what do you mean not included?

When installed, wifi should be active, it isn’t

I noticed that the Rock Pi 4 is no longer on your home page. Isn’t’ that a tacit admission that the board is defective? If so shouldn’t it be made right? should we all get replacement boards that support regular Linux?

? Erm, what? I never edited my home page to begin with. Also I’m mostly using cable for my 3 Rock Pi 4 since they sre working as servers for my lab.

Then just activate it? Like you know, not a single linux distro can magically connect to wi-fi unless you specify ssid, username & password

Well, the thing is. Rock Pi 4 IS in kernel support right now, so yeah, that exactly board that support regular linux

I have installed and maintain various Linux distros including Ubuntu Kbuntu,Linux Mint, Rasberian, Debian , Kali. I have used old PCs and Laptops all with WiFi. No problem. The Rock Pi 4c plus won’t accept a password and refuses to install. I believe the problem is with Kwallet and certificates.

Can you provide a screenshot of the rejection dialog box?

Who is the manufacturer and Model of the chip set for the wifi module on the Rock Pi 4c Plus?

Please check the model of the wireless module first:

  • AP6256: Broadcom BCM43456
  • AW-CM256SW: Infineon Cyw43455

I noticed that image for 4B+ loads device tree for 4B only although the correct overlay “rk3399-rock-pi-4b-plus.dtb” is included in /lib/linux-image-…/rockchip. The same happens when the image is built using “rbuild”, only 4B device tree is loaded. Thus only 1.8 GHz max etc. Is it possible to select different DT manually?