Rockpi 4b Debian or Ubuntu with Kernel 4.14 or higher

i would like to know if there is any debian or ubuntu image available with a kernel version 4.14 or higher?



Starts with 5.1 but after and update apart from pcie 5.2 is now working.
You should be able to grab the current stretch / bionic and build 5.2 mainline.

I am actually wondering why @radxa is not supplying build scripts for Buster & Ubuntu with 5.2+ mainline as the additions to the build script would seem minimal.
Also slightly worried why @radxa have not submitted rockpi4 pcie dts submissions as its likely where they will need to reside.

thanx for your answers. The thread about Mainline support is half a year old with no
real solution. I could not understand why some boards start with a kernel that is so old.
I tried armbian images but the nightly with dev kernel 5.1 won´t boot.
I build a kernel for armbian but its the same, it boots… uboot shows up and then nothing
But Ok, i try it in a year or two, to be used from odroids…bananpi and all the othrer crap.

Mainline is now running hence the above Manjaro distro version?
But from any 4.4 running version you can try compile the mainline kernel and install or wait until Oct as Ubuntu 19.10 will be running 5.3 which is likely also to be the next LTS.
I doubt Radxa will bother with 4.19 the current LTS as 5.3 is so near and complete.

Haven’t used any of the Armbian images but don’t know if the Rockpi4 is supported as usually experimental images turn up in ‘other downloads’

I am bemused why Debian Buster being a different repo doesn not stop using the linaro version and just pulls in via debbootstrap or the ubuntu equivalent as packages for both distro’s are now 100% complete hence why Linaro has halted.

Prob just needs a new build repo but much is just pull in mainline uboot, mainline kernel and a rootfs and just copy and modify some of the original scripts.


i solved my problem. I contact the store where i get the rockpi from and i can send it back.
I order a raspberry pi 4 with 4gb ram.

Thanks for your help.


First, you need to understand one thing. It’s np radxa who create kernel for rockchip. It’s rockchip who patch kernel and add all necessary stuff in it. And 4.4 is what all rockchip devices have. Even RasPi was sitting at it, until others devs said that they will support RasPi and patch new kernels.

Second, if it’s not booting - then you wrote it wrong on emmc/microsd.

Third, if you would actually read thread i linked by yourself with search BEFORE purchasing or creating this useless thread - it would be better. Why do you think people was answering in that thread? For ppl like you to be able to find answer without creating yet another thread.

Fourth, just using new kernels breaks a lot of stuff, it’s not Intel’s processor. You can look at AMD and latest kernel for example

Fifth, goodbye.

i understand that, but i didnt want to spend much more money for crap like this. search the forum for problems like use both emmc and m2 then the m2 adapter is to close to the emmc card, if you mount the
big heatsink - which is needed - then you have to disassemble the heatsink every time you need to change image or emmc… if you mount the m2 with this short short cable you need fingers like a chinese baby to switch sd card… and so on. but you can use whatever you want… and i too.

Second, if it’s not booting - then you wrote it wrong on emmc/microsd…
I try several Images Ubuntu, Armbian all boot after flashed them with etcher but the dev5.1 Images from armbian not… if all the other images boot how could i flash the dev image wrong??

Even RasPi was sitting at it, until others devs said that they will support RasPi and patch new kernels…
Sure, but Raspbian Stretch is now at 4.19.42 and if rockchip do not upgrade their software perhaps
Radxa should do?

Same at Android… or is it normal to build a android 7.1 image with no possibility for shutdown??

I am only a stupid electrician, but if i do my work like some companies who build hardware or software
i could go directly to jail…

1 Like

Not really. And if you buy silent 5v fan from Noctua - small heatsink more than enough.

It was told before - you don’t need to. There is enough space to do that.

And it’s not like only RasPi devs did that themself. It was actually multiple support (including Broadcom).

Don’t ask me what you did it wrong, ask Armbian guys about this. I can only say that it’s problem i met before while i was playing with Firefly rk3328-cc, one time I wrote image - no booting, i wrote same image on the same mSD with the same PC - and it’s boots.

Well. I don’t buy mini-PC for Android. For this you have 10-30$ phones. So can’t say is it normal or not

you told me the big heatsink is not necessary only the small with heatsink - ok, but i have only the big one
and use this. And with the big heatsink mounted there is not enough space to change emmc.

If you get a android phone for 10-30$ with a 19 inch touchscreen please tell me a link for order
And when the android image is not necessary or useless why does radxa develop it?

In Anrdoid TV Image there is a power button… but no touch… thumbs up!!