Rock5 does not work on most PD power supplies

Yeah my board is also a retail one, pre ordered months ago… delivered by AllNET

So far it seems that we all just got an old U-Boot and basically no way to update it, without using an external flash device. Which is kind of not my thing on a freshly bought retail product.

I have flash programmer, but the flash (MX25U12832F) is located at a place where I cannot use a clamp cable to flash it, so I dunno what can be done next, sigh.

1 Like

you could desolder the flash chip (warning that would void warranty) and solder it on an brakeout board and stick it in to your programmer and then solder it back on (tools required: hot air station soldering station solder flux and twiizers)
or you could do it in software (idk if it is allready supported in flashrom)

lol, this is a retail product.

I hope there will be a solution to update the flash from a running OS soon.

I presume you need a usb-c-5v non pd power supply or 12v adapter and Radxa will just push updates to the repo.

I will try again :slight_smile: @jack @RadxaYuntian

Desoldering is never an option, just as @DooMMasteR said, for a retail product, especially that it is newly purchased.


thats right thats also why i wrote it will void warranty

It’s not about warranty, but all the hassles involved. It could easily take a few hours, and there is a certain possibility of damaging the SBC during the operation (happened to me before). Using a clamp cable to flash is the boundary to me, as it is still “easy to do”.

i typicaly need about 30 minutes to remove flash and solder it back on
but i did it often
and i never broke something with such a action but fixed 4 devices

Yep, as you do it often, so you should also have proper setup at home or office to do so; not everyone have access to such a setup… say, why would you think hot gun is a “common equipment” for a retail customer? And you didn’t break anything during all these is good for you, but it should not be an expectation of what a retail customer can do. I would only consider myself hobbyist, and I don’t want to touch my soldering iron unless I absolutely needed to.

i understand that thats why flashrom can flash the bios of the computer its running on and hopefully it can soon do that with the rock 5b but until it is possible there is no real way arround the soldering iron

I am afraid it is not that easy… since Radxa made it a masked ROM, so under normal operation it should be read-only, and upgrading from OS (i.e. flashrom) may not be possible at all, which in itself is a good security feature (ARM TrustZone?) but worked against me for the time being.

I guess Radxa may need to fix the current flash tools they have, in order to make it work.

i looked in the schematic and the eeprom i fortunaly not hardware writeprotected so if its protected its “only” a software protection

Could you please explain why you can’t use maskrom mode to update spi flash? As specified in the official doc

i think you can update the spi flash in maskrom mode atleast in linux (pc not rock 5b)

you may see my reply #20 in this topic

At least for me using the SPL loader does not work either.

~/b/rkdeveloptool (master)> sudo ./rkdeveloptool ld
DevNo=1	Vid=0x2207,Pid=0x350b,LocationID=101	Maskrom

~/b/rkdeveloptool (master)> sudo ./rkdeveloptool db ~/Downloads/rk3588_spl_loader_v1.08.111.bin 
Creating Comm Object failed!

~/b/rkdeveloptool (master) [1]> 

I also had to manually apply to make the tool compile.

The super wonky/sketchy Windows tool worked… got the boot-ROM updated and PD now works for me.

I guess it would be a great idea to either implement a working in OS upgrade path, update the U-boot before shipping or at least fix the toolchain needed to upgrade it.

1 Like

I have been able to update with rkdeveloptool… Use this to set the correct permissions

echo 'SUBSYSTEM=="usb", ATTR{idVendor}=="2207", MODE="0666",GROUP="plugdev"' | sudo tee /etc/udev/rules.d/51-android.rules

Then, make sure you are in the same folder as the image you want to flash. Second, run all commands pretty fast after booting, or all of them in the same line, including the reboot one.

I have managed to both update spi and flash the emmc with this tricks. Now my laptop PD supply works!

1 Like

what platform you use with Windows that works? e.g. CPU? Chipset? Run the tools with admin privilege?