ROCK 5B Debug Party Invitation

I didn’t understand what “v1.42” was standing for, whether it was a new blob version applied to your board or something like this. OK so there’s a new board version, I didn’t notice. IMHO it’s unrelated to the board but to the CPU only. We really need to do something so that all OPPs up to 2.4G are usable for everyone possibly with different power consumption based on different voltages, but even Radxa got the confirmation that 1.05V was acceptable for the CPU, so there’s no reason to limit oneself to 1.00V and make users suffer from lower frequencies than what they hoped they’d get. And I tend to think those CPUs wouldn’t be sold as 2.4GHz CPUs after they pass the factory tests if they can’t reach the frequency under the recommended working condition.

Yeah posted as seemed to be a different profile than 1st board.

@tkaiser @amazingfate @ willy @ stuartiannaylor
You may try this,change "rockchip,pvtm-volt " to a lower voltage,for example 0xb40dc.I found it’s may improve about 100Mhz on my rk3588s boad.
Essentially,this will change system pvtm calc at boot time.However over-voltage only get very limite improve(20mhz per 125 step).I almost sure:this will work on willy’s board,for his have similar params as mine.But I also found it may no worke at all king of boards.Some board with a very low pvtm ,will improve little.This is comparison:

[ 6.268105] cpu cpu4: Looking up cpu-supply from device tree
[ 6.269792] cpu cpu4: bin=0
[ 6.269965] cpu cpu4: leakage=9
[ 6.269986] cpu cpu4: Looking up cpu-supply from device tree
[ 6.276503] cpu cpu4: pvtm=1677
[ 6.280488] cpu cpu4: pvtm-volt-sel=4
[ 6.280521] cpu cpu4: Looking up cpu-supply from device tree
[ 6.281019] cpu cpu4: Looking up mem-supply from device tree
[ 6.281563] cpu cpu6: Looking up cpu-supply from device tree
[ 6.283235] cpu cpu6: bin=0
[ 6.283411] cpu cpu6: leakage=9
[ 6.283430] cpu cpu6: Looking up cpu-supply from device tree
[ 6.289911] cpu cpu6: pvtm=1700
[ 6.293866] cpu cpu6: pvtm-volt-sel=4
[ 6.293899] cpu cpu6: Looking up cpu-supply from device tree
[ 6.294398] cpu cpu6: Looking up mem-supply from device tree

mhz(avg for cpu4):2245.376

[ 6.260317] cpu cpu4: Looking up cpu-supply from device tree
[ 6.262000] cpu cpu4: bin=0
[ 6.262174] cpu cpu4: leakage=9
[ 6.262196] cpu cpu4: Looking up cpu-supply from device tree
[ 6.268691] cpu cpu4: pvtm=1634
[ 6.272670] cpu cpu4: pvtm-volt-sel=2
[ 6.272715] cpu cpu4: Looking up cpu-supply from device tree
[ 6.273216] cpu cpu4: Looking up mem-supply from device tree

firefly@firefly2:/boot$ ~/mhz 10 50000
count=516515 us50=11010 us250=55077 diff=44067 cpu_MHz=2344.226

After five day’s testing.I sure it’s stable enought for heavy load. But change “rockchip,pvtm-volt” will also change “pvtm-voltage-sel” 's decision and “opp-microvolt-L*” selection.You may like to edit opp-microvolt-L2 to L7 manually.
At last,Thanks for your help!

I don’t recommend you to change the measurement of pvtm value because no matter what you change, your soc chip is always not changed. It’s just like you change the unit of your weight from kilogram to pound. The default pvtm-volt should be ok and rockchip has make the current opp table based on many chips been tested. If you want higher frequency, just increase the clk opp voltage.

1 Like

Look this:
I over-volatge to 1.025V.
count=516515 us50=11293 us250=56472 diff=45179 cpu_MHz=2286.527
count=516515 us50=11293 us250=56479 diff=45186 cpu_MHz=2286.173

While stress…
vdd_cpu_big0_s0 1 3 0 normal 1025mV 0mA 550mV 1050mV
vdd_cpu_big0_s0 0 0mA 0mV 0mV
vdd_cpu_big1_s0 1 3 0 normal 1000mV 0mA 550mV 1050mV
vdd_cpu_big1_s0 0 0mA 0mV 0mV

If you want to see the current microvolt of the big cores, use this command:
cat /sys/class/i2c-dev/i2c-0/device/0-004*/regulator/*/microvolts.
To see the max mcrovolt:
cat /sys/class/i2c-dev/i2c-0/device/0-004*/regulator/*/max_microvolts.
2286MHz is higher than 2245MHz so your microvolt 1.025V should work.

If people want to OC then let them OC but the original cool running of the Rock5b has been killed with the OC over the default Rockchip set.
With the perf the rk3588 has I couldn’t care less if its not on the button 2.4Ghz and changing the default than saying its up to 2.4 Ghz and maybe refers to a single cluster and just accepting what Rockchip think is a default value and maybe giving the option of OC overlays is a bit nuts.
That lovely cool running SBC now has passives not able to cope and fans whining noisily even if all core 100% stress tests are synthetic, but currently temps are extremely high without the GPU or NPU running… Whats temps you will get with GPU & NPU running … ?

The OC guys should move to an OC thread and continue to see what they can get but likely I will not bother with an OC.

Thanks,It’s a easier way.
root@Fly:/home/firefly# cat /sys/kernel/debug/regulator/regulator_summary | grep big
vdd_cpu_big0_s0 1 3 0 normal 675mV 0mA 550mV 1050mV
vdd_cpu_big0_s0 0 0mA 0mV 0mV
vdd_cpu_big1_s0 1 3 0 normal 737mV 0mA 550mV 1050mV
vdd_cpu_big1_s0 0 0mA 0mV 0mV
root@Fly:/home/firefly# cat /sys/class/i2c-dev/i2c-0/device/0-004*/regulator/*/microvolts

You are right!
So I content at 2340Mhz.All in all,It’s a rk3588s,a Cost-effectiveness SoC.
By the way,Without over voltage,power consumption increase very very low(about 0.05w).
In chinese,There is a saying:

@solaris3308 by all means continue testing and hacking and finding out absolute max perf as its great info and maybe overlay(s) can be made.
I would really like the lovely cool running and headspace of package temps to return in the default image.
Its funny really as got my 2nd Rock5b and been thinking there is something a bit c-rap about that Blue heatsink I got with the order whilst its the changes Radxa have made to Rockchip default :slight_smile:

I would rather have the Rockchip BSP default and if 2.4Ghz or max on a single cluster, or via OC I really don’t care, maybe Radxa should just put a ‘Max’ in the sales blurb for those who have a more literal interpretation of meaning.

@solaris3308 Is it just me as I can not find a difference in the OPP table as my memory is notorious but for some reason I got it in my head the SoC ran very cool.
I haven’t looked for a while as been playing with the GPU and maybe because I only tried a passive for a short duration, maybe its the stress-ng test and I was doing a lighter load or things are running hotter?
I have prob gone through a timewarp again or something but I am sure this is getting hotter quicker and attaining hotter temps than when I 1st tried?

With the 16 GB model, has anyone run into low memory situations yet?

My attempt at that failed, only 6.5 GB used according to htop:


What do I see, the elder scrolls III?


Has anyone got HW decoding working properly?
Rockchip dropped support for FFmpeg and advised to use the gstreamer white elephant, but i was still unable to make it work with gstreamer. I can decode H264 but with lots of dropped frames, anything else can crash kernel 5.10.66.

Running with kernel 5.10.110 is more stable but still a lot of issues with rga (and possibly mpp).
I haven’t followed the progress of the official image and the like, is it ready to use the hw decoder?

I dunno as I posted that a lot of work had gone into stateless decoders and that like the Hantro RKDec will benefit from this.
But was told this is not true, but haven’t done any tests or work but it would seem contary to Collabora claims.


FYI, hw decoding is fully working on a 4GB version.
The problem is with librga 1.8.1 which breaks rga conversation if > 4 GB. Tested with 5.10.110.

1 Like

Is librga 1.8.1 current or we just stuck with it due to dependency hell based on 5.10?

Radxa image used the librga 1.7.y which i think has some fixes. I used the one from sdk released on gitlab. There were a lot of toybrick related thing in the image that break dependencies, so i decide to build it from scratch.

A Rockchip member told me this should be fixed on the new SDK, i asked Jack and he said Radxa is working on this but it can take some time. At least we know where the problem is.

I have not tried mainline yet.

1 Like

Will be great to see some ‘stats4nerds’ when running or is it only via gstreamer?
I have a 8gb…

Tested with ffplay.

rock@rock5b:~$ uname -ra
Linux rock5b 5.10.110-debugx #3 SMP Wed Nov 9 14:25:40 -03 2022 aarch64 aarch64 aarch64 GNU/Linux
rock@rock5b:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04.1 LTS
Release:	22.04
Codename:	jammy