Radxa phone with cellular module

I finally received the modem, I’m running Armbian with kernel Linux rock-5b 5.10.110-media works with the sim in the card directly or in the adapter, but the modem manager gui stops, it only works with the gnome or xfce interface. What alternatives do I have for SMS and phone?
I mention that I also ordered an adapter for the M2 E with a SIM slot.
Thank you.

Well, you tell me :slight_smile:
I think it is good to reuse what is already developed, so I see using Android for phone functionality is the way to go. I could not make RIL for Android work yet.
My ideal result would be running Armbian on rock5b and Waydroid on top of it. But I need to build custom Waydroid image. So this is step by step plan

1 ) Make and Android image that runs on rock5b directly and makes phone calls
2 ) Apply the same changes to custom Waydroid image so that I can run rock5b as desktop (using armbian or rebornos) + as phone (using waydroid) at the same time.

Can you please place link to the modem a d adapters you are mentioning?

I wanted to use applications from Pinephone or is there PITalk, the problem is also with the sound transmitted via usb, the modem must be activated without having Modem manager Gui, I cannot try with sms,
do you have anything concrete? Adapter link: https://www.aliexpress.com/item/4001192388617.html?spm=a2g0o.order_list.order_list_main.5.21ef1802Sj19os

Is the adapter good? Please PM me how you managed to send sms and talk. That’s what you stated above (Aaaand the POC is ready. I had my first phone conversation through Radxa Rock5b).

Did you order the adapter?

I am using an adapter to USB.

Ok me too at the moment. I also ordered the other one and I don’t know if it has a place on the board?


I used serial console and executed AT commands
But for normal usage there is a need for UI and I dont know about proper UI app for phone call and SMS on linux. Maybe I can find or even develop one myself. But I would rather use Android on rockb inside armbian.

Trying Android AOSP eats so much resources, I moved all my VMs setup into slow disks so that can dedicate fast storage NVMs to building Android.

That is why I currently dont have access to my notes with the AT commands I used. Will share when I get them, if you dont find the way beforehand.

I tried the adapter, it works perfectly!
I also tried some AT commands for voice mode, they don’t work.
And another thing, as long as the card is connected to the modem, my number rings busy.

it works perfectly

What functionality is working? I would suggest strart with SMS instead of voice calling to make sure you can interact with the GSM network. Initially I used this utility called gammu

gammu sendsms* TEXT 082111978168 -text "Halooo

And also try AT commands from GSM modules manufacturers documentation. There can be small variations between modules.
For calling I used this one but there was another one to put the modem into right state for calling.


When you make call you will need to forward voice from your microphone to modem and from modem to your speaker. At that stage you are having normal phone like voice call.

Then you can help me out to make it work on Android.

SMSs work perfectly in windows and linux for voice, I gave the same commands in windows, it is a more advanced application, I activated the USB transfer for calls and voice, an AC device appeared in the audio
Someone said that it doesn’t work with the latest firmware, I don’t know if it can be downgraded.

With their application I cannot dial no. What’s with that 3?

on the linuz phone it works perfectly
I have a 316 page company order manual!

If you are asking about ATD+31111111;
That is supposed to be the number you are dialing.

I was using minicom to connect to serial device(modem).

AT commands

That sounds serious. Let me try to switch my previous setup where I made it work. You can contact me on Radxas discord channel

OK Yes version 2.0

How did you manage to use the modem without a sim reader

Check the link of the USB converted device
It has a SIM card
Actually the GSM module itself also has SIM slot
I booted the previous machine I was working on, one problem I don’t have a second phone to call for testing. Do you know any number just for echoing or something?

I am on discord, If you join there we can have a chat.