NVMe boot? Needs updated uboot?

It is not possible to deliver that little. Resolving one bug in open source software (full time professionals needs lets say 3 weeks to nail down) that was not provided or developed by Armbian exceeds donations per one year while you don’t even notice that bug existed or was fixed. Just one small example …


Remember when you will find something doesn’t work …

I have no debate with you on that. The value provided by Armbian is massive and should be supported. It does take a lot of work by many contributors to achieve that success. Other than the Raspberry foundation I can’t think of any group that has done more to drive the small SoC ecosystem forward.

Armbian should be supported by contributing bug reports, code contributions, code reviews and testing. Any supported by Money donations.

My point is this - your negative, whining & complaining attitude on this forum (and on various other forums that you post on) has done absolutely nothing to encourage anyone to make these very contributions. On the contrary. I know about a dozen previous contributors that have now sworn off ever contributing to Armbian again solely because of the negative light you currently shine onto the Armbian community.

I mean really - I come here and make a post that casts Armbian in a positive light and suggests hope that it will allow the Rock5b to become useful. And you choose to respond by attack. Not good form at all. That does not serve the very objective you hope to reach.

My remaining hope is that you can find a way to get past this bitter phase of your association with Armbian. Otherwise, we may in the future be discussing the Armbian project only in the past tense.

1 Like

“Should” doesn’t pay the bill.

Can I just be the fangirl and just comment that I love your youtube channel and all your Pi tests and projects? Good to see you around Radxa’s house. Hope you will be enjoying it, and do stuff like radxa zero cluster or something crazy like that :grinning:


Ha! Well, I’m just happy the Radxa Taco board is finally shipping. So far that’s my favorite little CM4/CM3 accessory yet!

1 Like

are u that guy who made a video about Microsoft Volterra on youtube?

I also am interested in taco board, but the weakest part of it is that CM3 module. Certainly it’s 1x pcie 2.0 lane + usb is bottleneck and for now I think that it’s just better to build same thing on rock5 board. Maybe some other CM modules will be available with more and higher pcie specs, but still I’m not sure if that is already connected in taco. AFAIK You have radxa module, I know that some on RK3588(s) are planned. Still wonder how that can be compared to rock5 with up to 8 m.2 satas, still somehow usable usb and of course eMMC.

@geerlingguy こんにちわ from Tokyo Jeff. I am glad you’re trying out a RADXA board! We’ve had problems with gpu acceleration on the OS using Ubuntu builds. Looking forward to you covering this board on your channel!

I have a bricked board trying to get it to boot from NVME - followed the instructions but no luck, tried booting with different images as well, and with a SD card that worked fine before I flashed the SPI image.

Can you tell us what exactly you did differently?

I did in this order ->
Installed the drivers for windows
downloaded the tools
Booted the board in MASKROM mode and confirmed it was connected
load the cfg file for spi
selected the spl_loader file for the LOADER row ( first row )
selected the rockb spi img file for the IMAGE ( second row )
clicked “run” with write by address enabled

Tried it 6-7 times with different usb ports, different images to boot from, etc - no luck at all.

Got it to work - found out two things
For some reason it won’t work from a windows flash but it will mac/linux?

The Ubuntu image does not boot from NVME, only debian does.

I ran into this as well. There must be something wrong with the instructions about how to use the rkdevtool in Windows. The very first time I used it there was no problem flashing the SPI NOR, but after I followed the instructions on how to erase the SPI NOR in Windows I could never get rkdevtool to work again to flash it in Windows. Its like the Erase All method cleared some important bit that is required for rkdevtool to work properly.

The symptom of failure is that it would look like it was doing a bunch of stuff to get the SPI NOR ready, but it would finish after only around 10 seconds with no error when I know for sure that the SPI NOR takes over 100 seconds to flash.

Flashing the SPI NOR directly from the rock5b using the instructions on the wiki after booting from SD card and fetching the boot image from the internet with 'wget ’ worked fine every time. I also booted my desktop PC from Ubuntu and used rkdeveloptool to program the rock5b over the USB-C to USB-A cable in maskrom mode after compiling rkdeveloptool on it myself using the instructions on the wiki. Programming it over USB-C to USB-A cable in maskrom mode just never worked again on the PC for me after the first time.

I am having no luck at all using a mac:

sean@mac ~ % sudo rkdeveloptool ld                                
DevNo=1 Vid=0x2207,Pid=0x350b,LocationID=1404   Maskrom
sean@mac ~ % sudo rkdeveloptool db rk3588_spl_loader_v1.08.111.bin
Downloading bootloader failed!

Any ideas?

Are you in the right folder where the “rk3588_spl_loader_v1.08.111.bin” is located?

Type pwd to see the directory you are in and then a ls command to see what files are in that folder

Thanks for getting in touch!

The answer is “yes” I am in the same directory as all the files that were downloaded from the radxa wiki.

It seems from a lot of searching that a lot off people are having the same issue, but I can confirm that using the windows solutions worked.

Note that on first attempt it didn’t work, but once I used the erase utility the second attempt worked, and potentially erasing first could solve the issue, but I’m reluctant to go through the process again.

problem solved - Chrome downloaded the .img files and relabelled as .dmg…

1 Like

For those who are interested in a system with EFI\Grub on NVMe, including without having to write something to SPI, while maintaining the launch of any systems from an SD card. :stuck_out_tongue:

What about eMMC? Will that one boot when inserted?

It should work, but I haven’t checked (there is no such hardware with eMMC modules).

emmc boot works fine on rock5b as it does with sd

1 Like

Thanks a ton @geerlingguy

Your reviews are golden, as always!