Nextcloud on Ubuntu Server - Can't reliably download multiple files simultaneously

Rock Pi 4 A 4GB

Hi guys,

im having some weird problems with my nextcloud instance on my Ubuntu Server on the Rock Pi :slightly_frowning_face: I suspect it has to do with my Apache server.

So the problem is: When I download many files from my nextcloud server, the download stops after a seemingly random amount of seconds (between 1 and ~100 seconds).
I don’t have issues downloading a single large file with for example 32GB. I also have no problems uploading any amount of files to my nextcloud server via a webbrowser or the windows client. The issue is solely isolated on downloading multiple files at once from the nextcloud server. I also have tested, that with SFTP i can download 20 files simultaneously without any problems.

I opened a thread on Nextcloud Help too (click the link to see log files and more infos about my issue), but i feel this might be a problem related to Rock Pi and it’s Ubuntu Distro…

I guess my question is, has anyone on the forum tried nextcloud on a Rock Pi 4 and did it work flawlessly or did you have a similar problem?

Regards :slightly_smiling_face:
Gee

What do your next cloud and system logs say?
Post as otherwise blind

Hi, thank you for your interest. I have a lot of logs in the linked thread of my initial post… but i guess i can repost them here.Why not

Nextcloud log

Failed download large log
16:02:38 Download Begin
16:02:39 Download stops itself
16:02:52 User cancels the download

A lot of more log files are in the before mentioned thread - i can only post 2 links per post yet

I will start to set up nextcloud tomorrow it has been a while but will be a good quick little project.
USB storage is that where the files are stored?
Looking at the errors my gut says its config somewhere.

  1. Yea, your experience would be much appreciated
  2. Yes
  3. I thought that too, but can’t find anything wrong with my configs… will try anything you suggest. I have a feeling it might be actually a bug tho :frowning:

Besides, the errors in the Nextcloud.log posted above did not reoccur. They are kinda out of date now. I don’t understand what the error is telling me right now, but i think it’s not related to my problem, since I still have the same problems even though no new errors are logged in the nextcloud log

@stuartiannaylor
I actually kinda solved my issue. I disabled both Gzip compression AND SSL.
When i tested disabling Gzip ( mod_deflate ) yesterday, I had SSL enabled back again at that point, because i expected to have only a single problem in my nextcloud installation. That’s why i still had problems downloading. Apparently, both SSL AND deflate caused issues in my installation (so an SSL bug might exist at my setup) .

I still can’t download multiple files as a ZIP file via the browser. That might be related to Gzip again, but that’s not so important for me.

I guess we can close this thread. I wish you good luck :four_leaf_clover: with your installation @stuartiannaylor . Nextcloud is pretty neat :slight_smile: almost as neat as the Rock Pi 4 hardware :sweat_smile:

1 Like

I was just going to make breakfast and start :slight_smile:
Glad you got it

1 Like