Newbie questions


#1

Ok, I bought a Rock 4B directly from Radxa in Baoan. The board was straightforward to assemble and the OS came up straight away.

The first thing now is to get wifi working.


#4

I have installed xfce and then used xfce’s wifi config tool to get wifi working.


#5

tl/dr: the latest version of Chromium does not work on some ARM systems (this is a Chromium issue). The work around is to downgrade to an earlier version.

Downgrade to the earlier version e.g. sudo apt-get install chromium=63.0.3239.84-1~deb9u. (Check available versions using: sudo apt-cache policy chromium)

Here is what I am getting from Chromium:

linaro@linaro-alip:~/Desktop$ chromium &
[1] 1454
linaro@linaro-alip:~/Desktop$ [1493:1493:1111/065436.912146:ERROR:sandbox_linux.cc(379)] InitializeSandbox() called with multiple threads in process gpu-process.
Received signal 11 SEGV_MAPERR 000000000000
#0 0x0000ac44bfb0
#1 0x0000ac3d86c4
#2 0x0000ac44c2a2
#3 0x0000ac44c4e4
#4 0x0000f2ea7fe0
#5 0x0000ab1810b0
#6 0x0000ac6c9ff4
#7 0x0000aca86996
#8 0x0000ad37cf9c
#9 0x0000ad37d068
#10 0x0000ad37d13c
#11 0x0000ad37d1c4
#12 0x0000ad37d1f6
#13 0x0000ac3211b8
#14 0x0000ac3211f2
#15 0x0000ac1d5378
#16 0x0000ac1d93cc
#17 0x0000ac1d963a
#18 0x0000ab611c9e
#19 0x0000ab855996
#20 0x0000ab61834a
#21 0x0000ab618832
#22 0x0000ab61393e
#23 0x0000ac1b852c
#24 0x0000ac1b8d52
#25 0x0000ac1bd6b6
#26 0x0000ac1b8330
#27 0x0000ab005290 ChromeMain
#28 0x0000f2e994aa __libc_start_main
[end of stack trace]
Calling _exit(1). Core file will not be generated.

Edit, note to self, from web searches:

This seems is a known issue.

Try running options --disable-gpu or --disable-gpu-sandbox and --enable-native-gpu-memory-buffers

Try deleting /home/$USER/.config/chromium/


#6

Hi, martin

Thanks for visiting us. You are the first to come directly to our office and buy ROCK Pi 4! This is unbelievable.


#7

Yes, it was good to actually meet the people who created the product.


#8

I ran into the same problem yesterday after sudo apt-get upgrade chromium.

The original post was from Nov 2018, and now it’s late February 2019, the problem is still there, very disappointed.


#9

For what it’s worth, I switched over to the 64 bit Ubuntu image and I haven’t had any problems since.


#10

did you use the image listed as ubuntu server from:
https://wiki.radxa.com/Rockpi4/downloads


#11

No. I’m trying to use this Rock Pi4 as smart home gateway, the entire chain are built for armhf (a k.a Raspberry Pi family). Not every piece is open source, besides it’s just too much to compile everything from the source code, who knows how many more problems I’d run into. I’m still struggling to make pin8/10 TxD/RxD working at this point, likely I have to build the kernel just for enabling one serial port, this Linux ecosystem looks less and less appealing.


#12

I was hoping pin 8 and 10 would be identified as /dev/ttyAMA0 or /dev/serial0
I think it’s going to take more work… all I need is a single uart


#13

Have you had a look at the RockPi Wiki? Especially the end of the hardware section might be interesting for you. It deals with the serial ports.

40-pin GPIO connector
8 GPIO4_C4 DEBUG_TXD
10 GPIO4_C3 DEBUG_RXD

After looking at the GPIO connector and the following additional explanations, I interpret it like this: pins 8 and 10 are currently used for debugging. However, pins 19 and 21 are suitable as UART for users. I haven’t had any experience with UART4 yet, but maybe you’ll see if you can get further with it.

40-pin GPIO connector
UART4_TXD SPI1_TXD GPIO1_B0 19
UART4_RXD SPI1_RXD GPIO1_A7 21

More details about 40-pin Header

For UART4-TXD/RXD
By testing, it supports a wide range of baud rate. It includes but not is not limited to the following baud rates. For instance, 115200bps. 500000bps, 1500000bps and so on.

https://wiki.radxa.com/Rockpi4/hardware/rockpi4


#14

My application is attempting to use add-on boards that have been setup for other single board computers (SBC). If I can use a software overlay to re-define the mapping of the uart gpio to match other SBC’s then the Rock pi 4 should useable.

The designation ‘DEBUG_TXD/RXD’ is not helpful for the pins 8 and 10. I would assume it is a uart interface. If so… than I just need to configure it as such.


#15

I;m trying to use the Z-Wave HAT designed for pin 8/10, I know many HATs on the market are using pin 8/10, if I want to use pin 19/21, then I have to find a way to secure the HAT and wire it with bunch of jumpers just too awkward. I see the advantage if I could use pin 19/21 for some HATs tho, I may be able to install multiple HATs, like Zigbee along with Z-Wave on the same board. But for now, I just want to make pin 8/10 working.

I think I’m going to build the kernel since the Wiki said device tree overlay is not ready. But the problem is I can’t find how to configure the pin in DTS. I’m reading rockpi-4b-linux.dts and rk3399.dtsi, honestly I’m lost. I don’t even know which uart the pin8/10 is, it’s not as intuitive as Rasbian dts (well Rasbian is still a mess).

Is fiq_debugger the DEBUG_TXD/RXD we are talking about? the pinctrl is uart2c in the dts, is uart2c pin 8/10? In rk3399.dtsi it’s saying:
uart2c {
uart2c_xfer: uart2c-xfer {
rockchip,pins =
<4 19 RK_FUNC_1 &pcfg_pull_up>,
<4 20 RK_FUNC_1 &pcfg_pull_none>;
};
};
how are these rockchip,pins mapped to GPIO pins? It’s getting really irritating.


#16

I mean, if fiq_debugger is the DEBUG_TXD/RXD and uart2c is pin 8/10, I can just point the pinctrl-0 to somewhere else like &uart1_xfer to free up uart2c/pin8/10, right?


#17

Quote from another post of how this issue is solved:

Configuring kernel before building

Here is the steps I did:

  1. add “deb http://apt.radxa.com/stretch/ stretch main” to /etc/apt/sources.list
  2. get the repository key: “wget -O - apt.radxa.com/stretch/public.key | sudo apt-key add -”
  3. update your apps: “sudo apt-get update && sudo apt-get upgrade”
  4. install rockchip-overlay etc:
    sudo apt-get install rockchip-overlay
    sudo apt-get install rockchip-fstab
    sudo apt-get install rockpi4-dtbo
  5. edit /etc/hw_intfc.config, turn on uart2, uart4, and the overlay disables the console.
  6. update kernel:
    apt-get install linux-4.4-lastest
  7. update u-boot:
    sudo su
    apt-get install rockpi4b-rk-u-boot-lastest
    cd /usr/local/sbin/
    ./rockpi4b_upgrade_bootloader.sh
  8. reboot, type “who” in xterm, should shows you as the only user, nobody on ttyFIQ0
  9. In Z-Way server or Home Assistant, change the default uart setting from ttyAMA0 to ttyS2.
  10. reboot. who says you don’t need to reboot Linux often? :-/