My Zero Wifi is not working

I have confirmed that the 20220311 Android build has working Wi-Fi on CM256.

@RadxaYuntian Thank you for taking the time to look at this.
My problem is still there. I will try to make some screenshot and look at the Android log and post it here.
Maybe somebody knows more…

You can capture logs in serial console. Something like dmesg > kernel.log then sending the file can be a helpful first step.

@RadxaYuntian


Board model: Zero 4GB/16GB D4E16H v1.5 with AW-CM256SM wireless module


Since I cannot test the board with the console right now, I have attached the logcat file from Android (it contains the kernel logs too).

adb logcat -b all -v threadtime > logcat.txt

logcat.zip (1.1 MB)

Some notes about the log file:

  • I have anonymised all MAC Address by replacing them with ab:cd:ed:01:02:03, just in case you wonder
  • Our Wi-Fi network is called AllNet WiFi
  • At time 11:58 I started to play a YouTube video, as you can see from the screenshots below
    10-25 11:58:54.247 4206 4206 D NowPlayingListener: updateNowPlayingNotification with controller: NowPlayingMediaController {packageName = org.mozilla.firefox, state = 3, metadata = TV für Hunde! 8 STUNDEN lustige Unterhaltung für gelangweilte Hunde + Musik! NEU - YouTube, https://m.youtube.com/watch?v=I4KCmFfVm34, null}
  • The problem shows up around time 12:02.
    10-25 12:02:00.160 0 0 I : [ 790.252331@2] CFG80211-ERROR) wl_cfg80211_hang : In : chip crash eventing, reason=0x8002
    ...
    10-25 12:02:02.854 4601 4601 D wpa_supplicant: wlan0: State: COMPLETED -> DISCONNECTED

  1. YouTube playing for about 5 minutes
  2. Wi-Fi disconnects on its own

  3. In the Settings of Android there are no Wi-Fi networks anymore!

  4. Wi-Fi shows up and reconnects only after turning it Off then On
  5. Wi-Fi disconnects again after some minutes

Here a short screen capture showing the problem.


Can this problem be something like the one described here?

1 Like

I have requested our testing engineer to follow what’s described here to try to reproduce it.

2 Likes

We have reproduced this issue. We have assigned this to our Android engineer to investigate.

2 Likes

Thank you very much.

1 Like

Excuse me. What Android are you running? What FPS do you get in youtube?

@RadxaYuntian
Is there any news regarding the problem of the wifi disconnecting on Android?
Do you plan to release someday a new version of Android 9?

Alternatively, I can try recompiling the kernel myself, if you can tell me what needs to be changed

1 Like

Hello @RadxaYuntian
I have the same problem with Android, where the WIFI that keeps on disconnecting on its own.
Do you have any news about your tests? Could you estimate how long will it take to solve this?
Thanks!

1 Like

@RadxaYuntian

Due to the persistence of problems with the Wifi module of hardware revision 1.5, in conjunction with the use of Android provided by you, and noting that for 20 days after you ascertained the problem there is not the slightest feedback, we have decided here at AllNet Europe to suspend imports of this device and notified all resellers of the problem, who will take action and a possible stop on the sale of the product to avoid further complaints from customers who feel they are being fooled.

1 Like

We are still working on a fix here.

1 Like

@RadxaYuntian any update on the android fix?

@tceylon

Where can i get your modified slimbox x96 android image?

I also am having problems with two Radxa Zero version 1.51 boards I ordered. Even though they have the AP6256 chip on them which is supposed to be working, I can’t get either one to work, not even after several attempts with both. I tried following the procedures on the getting started page, but I have had no success.

When I use the USB Boot button to put it in Maskrom mode, I can see it with lsusb (I am running Fedora Linux 37), but nothing shows up in /dev to show the board is present. lsusb shows the text below:

Bus 005 Device 038: ID 1b8e:c003 Amlogic, Inc. GX-CHIP

I am at a standstill with these two boards. I would appreciate any advice in getting these to work.

I have a 1 G-bit version 1.5 (no eMMC) - Anything new about wifi connection and the possible subsequent stability?
No matter what image I use - Once in a while I can get wifi connected but it drops again!

I tried using the information here: https://wiki.radxa.com/Zero/getting_started, but was not having any success.

I downloaded the Armbian Jammy image and wrote it to a micro-SD card. I can boot with it, but even though I have tried both wired and wireless keyboards, I can’t interact with it through the second USB port. I found my Y cable through which I can connect both power and a keyboard, and I have been able to log in.

I will follow up, but it looks like Armbian activated the WiFi as I was able to get the Radxa Zero connected to my home network. I will do the same with the second Radxa Zero. Hopefully, it will work also. If successful, the next step will be to put the MMDVM hat on and see if it still connects to the network.

Infineon has provided some custom driver for our other CM256-based products to use on 5.10 kernel, but it is still not quite stable yet. Once that issue is solved we will ask them to backport to 4.9 kernel the Zero Android is using.

Do we have an ETA on this fix?