Mainline-Kernel not booting

I am following this official tutorial: for the debian image.

All went fine, however, at the end, the new kernel simply never is booted. Instead, it keeps booting the older kernels installed.

Trying to upgrade to a newest 5.2.11 kernel, as the old 4.4 doesn’t seem to support the CEC, and the CEC-feature should be working form mainline 5.1 as i understand.

Thanks for any help!

You can interrupt the startup and boot the kernel manually. Does this work?

Hello lucas,

If u-boot has not found Image or device tree from /boot/extlinux/extlinux.conf configuration , it will booting the older kernels installed.Please check your configuration and kernel/device tree path.

Can you show more log for us?

Hello there, thanks for your posts.

Maybe somebody has already compiled a 5.1 or 5.2 kernel into the Debian and can give us a ready download? :grinning:

@akammeyer I dont actually get to see the bootloader. I put the timeout to 1000 (100 seconds), it just stays black for this time, and then shows Debian

@Jubian Where can I find real logs for it?

I uploaded a few snippets here, including my current extlinux.conf and /boot directory contents.

What I notice, the original extlinux.conf is listing devicetreedir entries, whilst the one given in the tutorial only lists a single fdt entry:

label kernel-mainline
kernel /Image
fdt /rk3399-rock-pi-4.dtb
append earlycon=uart8250,mmio32,0xff1a0000 swiotlb=1 coherent_pool=1m earlyprintk console=ttyS2,1500000n8 rw root=PARTUUID=b921b045-1d rootfstype=ext4 init=/sbin/init rootwait

This fails with the same symptoms of just being ignored and loading an old kernel instead.

I tried to find a folder in my compiled output with similar data inside as in the old kernels, and make such a device tree folder in a similar location, but that didn’t work either.

Thanks for any help, hints, or a ready working image of debian with the latest kernels :slight_smile:


Sorry, I was assuming you have the board connected via UART. There you can access the bootloader.

Hello lucas,

We need logs which before kernel booting.

We will make a Debian which use mainline kernel and update download link on wiki, but you should wait a while,because we need solve some problems to fitting mainline kernel to ROCK Pi.

Please show those logs for me,thanks for your wait.

in the meantime maybe this will suffice.
Debian Minimal image with Kernel 5.3 for RockPi4b

Similar problems. I find the serial debug cable is useful.

Following the guide above on Linux results in dropped characters and console corruption, but PuTTY for Windows works. I am glad I ordered the debug cable with the board.

This gives some useful information. Unfortunately, if it fails to find what it needs for a boot entry, it seems to just grab whatever it can find, instead of failing gracefully. This can result in mismatched dtb / kernel combinations. But at least it tells you what went wrong in the serial console, so you can attempt to fix it.

My issue is that I am installing compiled mainline, and the kernel might be partially booting, or maybe not. The screen comes on with a blinking cursor after a minute or two, but nothing else. But the serial console does not work with this kernel. Mine was FIQ0 but I tried ttyS2 like you and that did not help.

Does anybody have any knowledge why some kernels do not work with serial console?