Introduce the Radxa Zero

Nah i didn’t do benchmarks. Tried to launch dhewm3 but it hanged on loading a map, though main menu was working pretty fast.
Idk, i’m just excited about a PC for 20$ that could actually do some PC tasks. I use it as a desktop connected to my 3d printer, so i can launch prints from any device on the network. But i also can control prints from this PC directly, or i or anyone else could search something online while at that room (my dad repairs tools and stuff there from time to time, so it’s convenient to be able to open a datasheet on the monitor).
Plus having a linux desktop that turned on 24/7 so i might launch something there that would do stuff while my main pc can be rebooted, updated or whatever… although i have rpi4 for that XD But 20$!!!

Yeah I guess its great for that and the g31 once with panfrost is much better than the Raspberry vc4/6

It seems to be very stable @2.0Ghz also, yeah with 1gb zram with 50% for swap will help.
Seems Manjaro don’t do a lxqt image anymore so prob would go for XCFE and bung

xfwm4 --vblank=xpresent --replace , then xfconf-query -c xfwm4 -p /general/vblank_mode -t string -s "xpresent" --create
In ~/.xprofile maybe

It prob lightest of them all but still the browser is likely to be the same irrespective.

I am hoping they do a 3 pack or something so it helps with P&P as yeah they are good value for money.

Oh, how do you overclock the board, that’s another thing to tinker with))
Well, browser actually usable with like 2-3 tabs, it’s just a bit slower than i’d hope it to be

Hmmm, i opened ~/.xprofile in nano. added two lines:
xfwm4 --vblank=xpresent --replace
xfconf-query -c xfwm4 -p /general/vblank_mode -t string -s "xpresent" --create

and now it boots, i can connect with ssh, but screen just briefly flickers with picture of black screen with the cursor, does this a couple of times then no signal. Connecting to it with nomachine just gives black screen

Install the device tree compiler

in the dts of boot there is the radxa-zero .dtc.
dtb to dts:
dtc -I dtb -O dts -o <dts_file> <dtb_file>
dts to dtb:
dtc -I dts -O dtb -o <dtb_file> <dts_file>

Covert from binary to text and then back again after making changes, just keep a copy or orig as .old

You will find the cpu opp table in there and change so it looks like

	opp-table {
		compatible = "operating-points-v2";
		phandle = <0x45>;

		opp-100000000 {
			opp-hz = <0x00 0x5f5e100>;
			opp-microvolt = <0xb2778>;

		opp-250000000 {
			opp-hz = <0x00 0xee6b280>;
			opp-microvolt = <0xb2778>;

		opp-500000000 {
			opp-hz = <0x00 0x1dcd6500>;
			opp-microvolt = <0xb2778>;

		opp-667000000 {
			opp-hz = <0x00 0x27bc86aa>;
			opp-microvolt = <0xb2778>;

		opp-1000000000 {
			opp-hz = <0x00 0x3b9aca00>;
			opp-microvolt = <0xb2778>;

		opp-1200000000 {
			opp-hz = <0x00 0x47868c00>;
			opp-microvolt = <0xb2778>;

		opp-1398000000 {
			opp-hz = <0x00 0x5353c980>;
			opp-microvolt = <0xb9ca8>;

		opp-1512000000 {
			opp-hz = <0x00 0x5a1f4a00>;
			opp-microvolt = <0xc11d8>;

		opp-1608000000 {
			opp-hz = <0x00 0x5fd82200>;
			opp-microvolt = <0xcae18>;

		opp-1800000000 {
			opp-hz = <0x00 0x6b49d200>;
			opp-microvolt = <0xef808>;
		opp-2000000000 {
			opp-hz = <0x00 0x77359400>;
			opp-microvolt = <0xf9830>;

base-devel is archs version of build-essential think dtc is in there

Dunno maybe its because .xprofile runs on start before the window manager.

Guess ~/.profile which is just as your sessesion starts or create script and add it to aurostart.
Pretty sure I ran as root as expect x11 to do so, but try it without sudo in a cli to see if it works.
Otherwise you going to have to run as root but like I said before prob hop onto the manjaro forums and ask in xcfe arm forum.

If you struggle I will flash the image and sort it out in the next day or so and post back.
To be honest I don’t know but likely will be fairly easy to work out.

Have a look at

### Number of workspaces changes unexpectedly

Keep in mind  *Xfwm*  assigns shortcuts to adding and removing workspaces. By default these are  `Alt+Delete`  and  `Alt+Insert` , respectively.

If the number of workspaces resets at login, change the amount  **after**  Xfwm is started. This is ensured by the  `sleep`  command. [[1]](


(sleep 3 && xfconf-query -v -c xfwm4 -p /general/workspace_count -s *number* ) & exec xfwm4

or, from [xfce4-session](


[Desktop Entry] Exec=sh -c "sleep 3 && xfconf-query -v -c xfwm4 -p /general/workspace_count -s *number* "

Seems they use ~/.xinitrc or ~/.config/autostart/workspace.desktop

Arch Linux is an amazing source of documentation but prob the DM conf could be used

Please add support the Dietpi

1 Like

AmazonBasics USB 3.1 Type-C to 3 Port USB Hub with Gigabit Ethernet Adapter
working like a charm on Armbian builds, Tested it with Armbian image from Radxa and TwisterOS Beta4.

For those who needs to use a wired Gbit ethernet on their zero, this one comes in handy.

Gbit Ethernet connection over USB3 also uses also less CPU resources than a WIFI connection.

It uses a Realtek RTL8153 chipset to handle USB 3.1 to Gigabit Ethernet functionality and a VIA VL817 chipset for handling USB 3.1 Gen1 Hub Controller functions.

This USB-C hub ethernet uses only 180 mA Max when connected to USB3 port on Zero.


Since nobody from radxa team seems to comment my question about the I2S pins I can put it here too.
According to zero wiki Zero/hardware/gpio - Radxa Wiki
pin 33 is NC and not TDMB_FS (GPIOAO_7).
If I remember right in the first version of rockpi S ver 11 was pin 22 not connected to FS and was corrected on version12. RockpiS/hardware/gpio - Radxa Wiki
Could it be something similar here?

Tried you’re minimal, xfce, and KDE etched onto SD card on 2 RAXDA zeros… no boot.

Twister OS image worked on the same SD card.

@jtremblant Great work! any guide to installing this to emmc?

Use Nand-SATA-Install from armbian-config.

Keep thread updated… not working with beta4 img.

Unofficial Armbian Ubuntu based with changed theme / design, some stuff on top, GPL licence violation, …

There is not yet any Armbian for this board. Check: Please use term “unofficial” “test” “preview” “development” Armbian until then.

For official Armbian, try perhaps here.

Thank you! It took us years to develop this useful tool. Currently we are seeking for ideas and resources to rebuild complete configurator from scratch.

Otherwise, everything is in the docs: In case you want to add something to them


Those are images for usb boot and doesn’t work with sd card.
Please try it with a usb drive.

The shop says that radxa zero’s ‘micro sd uSD slot supports up to 128G uSD card’ .
Does this mean that the largest boot partition that can be recognized is 128G?
What happens if I place a micro uSD card of a larger size (e.g. 256G) ?
Will such a larger micro uSD card:

  1. be bootable as long as the first partition is <=128G?
  2. even if not bootable, can still be used as an external non-bootable flash drive?
1 Like

USB audio recording works on Zero using different audio inputs: XLR, 1/4" Line in, TRS, and RCA.

Every single USB audio interface I own has worked like a champ on Zero board running TwisterOS Beta4 for audio input recording. Latest Audacity 2.3.3 tested. Amlogic USB audio codec on Zero working great.

Tested it so far with: Roland UA-1EX(USB audio interface), Zoom R24(USB multitrack recorder), Allen & Heath ZED 12FX(USB Multitrack Mixer), Behringer UCA-222 (USB audio interface)






As soon as this is available, let me know. I’ll pre-order

An initial device-tree for the Zero has now been merged and queued for Linux 5.16: The USB ports defined are currently just normal ports. I have a patch for adding USB-C capabilities but the fusb302 driver needs some polarity work before things will probe correctly. Normal USB support works fine for now. If you are using 5.14 or 5.15 kernel sources you will also need else SDIO WiFi module will not probe and load firmware correctly.

I’ve also submitted initial board support to u-boot, but those patches are unlikely to be accepted before the matching kernel changes appear in torvalds/master so 2022.01 will be the release that gets them.



Since you’re at it, would you know if it’s possible to achieve in the current mainline state something similar to what is done here: but for zero radxa? Or with any other kernel?