[Guide] Best Options for a Single Board Computer 🎮

Fixed it. Thank you.

New version includes steam pre-installed.
latest armbian jammy with minimal gnome desktop and amazingfate’s multimedia + panfork branch ,not much preinstalled just box86/64 with wine 8.2 and steam client

1 Like

Is there something that I’m missing here? I tied flashing the image to an eMMC using Balanca, but when I try and boot the system it says:

Begin: Waiting for root file system... Begin: Running /scripts/local-block ... done.
- Boot args (cat /proc/cmdline)
  -Check rootdelay- (did the system wait long enough?)
  - Missing modules (cat /proc/modules; ls /dev) 
Alert! UUID= XXXXXX does not exist. Dropping to a shell. 

Is there something that I did incorrectly when flashing?

Try flashing it with rpi imager and see if it still happens.

obs doesnt work it says could not find the qt platform plugin “wayland” in “”

vlc is a Qt 5 application. According to ArchWiki, to run any Qt application in wayland you need to install qt5-wayland or qt6-wayland and use the QT_QPA_PLATFORM=wayland environment variable to accomodate for wayland applications. For applications misbehaving in wayland, use QT_QPA_PLATFORM=xcb before running the application.

Source: https://unix.stackexchange.com/questions/598099/could-not-find-the-qt-platform-plugin-wayland

sudo apt install -y qtwayland5

See if it works.

it worked but i cant record the hdmi input with obs it is just a block screen

See if these help:

1 Like

Hi. I am using this image and the youtube playback on firefox crash.
Any idea? In Chromium works fine.

I don’t use firefox I did some search on radxa discord and it seems it crashes a lot to everyone on armbian… I have no clue…

Idea: put this into your .bashrc or .bash_aliases:

alias turbo_on="echo performance | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor /sys/class/devfreq/dmc/governor /sys/class/devfreq/fb000000.gpu/governor"
alias turbo_off="echo ondemand | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor && echo dmc_ondemand | sudo tee /sys/class/devfreq/dmc/governor && echo simple_ondemand | sudo tee /sys/class/devfreq/fb000000.gpu/governor"
alias turbo_powersave="echo powersave | sudo tee /sys/bus/cpu/devices/cpu[046]/cpufreq/scaling_governor /sys/class/devfreq/dmc/governor /sys/class/devfreq/fb000000.gpu/governor"

Then you’ll have 3 commands for three different performance levels, no need to copy paste.

1 Like

I just leave it on performance and thats it. :cowboy_hat_face: You know this image is not mine right ? :smirk: @monka is the boss.

Yes. “Your” didn’t refer to you, but to anyone. Anyone can put these things in their bash config files. Not just someone who made the image.

And by default the governor is not performance, so it will be reset to ondemand with every power cycle, even if it’s changed.

1 Like

Updated Thanks Master Incognito!

I was planning to do some light gaming, but I run games, that need DirectX to work. I have read somewhere that using “PROTON_USE_WINED3D=1 %command%” might do the trick.
The command is used in Launch section of Properties window of games in Steam Library, but I can’t access to Properties. When I click on Properties in Large Mode, Library section itself freezes. In Small Mode nothing happens.
I also can’t run Steam in Big Picture mode.
I haven’t made any changes to the system, except updating Ubuntu and Steam.
Has this problem occurred to anyone else, if so how did you manage to solve it? Would DXVK work, there are Vulkan-based versions out there?

This is recent development cthulhuturk… PtitSeb being the main men for all the wine box86 64 port is a big luck we have on our side… Its only understandable that errors and freezings like that will likely happen.
Best person to answer you those questions is at Radxa Discord channel #box86-64.
Not all games will work and some that do under the compatability list will need some terminal work to do.
Thats why you have to follow the project closely github discord etc…

Thanks a lot. I have been doing some trial-error myself with no luck.
I will try asking around then. Nearly every game with no DirectX need worked without compatibility issues (except sound) thanks to your image, only D3D11 is missing.


New update this includes ReDroid

Armbian + Android? Best of all worlds!
(Doesn’t include Steam).

Start first malior-droid then adb connect localhost:5555 after that scrcpy -s localhost:5555

1 Like

Hey, good work! I’ve just installed it on my NVME.
Quick test:

  • Sound via Headphone didn’t work
  • glmark2 Score: 1076, to low

andreas@rock-5b:~$ glmark2-es2-wayland

glmark2 2021.02

OpenGL Information
GL_VENDOR: Panfrost
GL_RENDERER: Mali-G610 (Panfrost)
GL_VERSION: OpenGL ES 3.1 Mesa 23.0.0-devel

Do I have something to install, edit or add?

Trigger the performance mode and try the test again