Another correct way to boot from NVME?

Hi, I have followed this tutorial in order to boot from my lenovo NVME (phison chips)

It looks like a simple way to do it but after rebooting my rockpi, I end up with nothing happening for a long time, then after trying different things, I had “finally” a black screen with only a underscore blinking on the left top screen corner for a long time. then I had to log in (desktop not launching), like I was on a server version without desktop. How I can launch my desktop again ? My OS was on an emmc not sd card, would that be the reason why it has "failed "?
I entered into the armbian-config in order to find a reason but not sure what to do so before doing anything stupid I prefer to ask to the community.

Also another noob question but is the NVME really fast compare to the EMMC ? Thinking that if I cannot fix this, I’ll use the NVME only as a storage.

Never mind after several reboot it seems it worked, I haven’t tried without the emmc unplugged though… I’ll update this message when I 'll get some time in case it can help noob like me in this procedure… just for inforamtion I did some benchmark and read speed with lenovo NVME is 857 MB/s vs 238.0 Mb/s for emmc.

So I have finally tried to remove the Emmc card and it doesn"t boot anymore, I am maybe missing a step. If anyone knows what could cause this issue let me know. Only the Nvme is showing on the file manager under “device” , it is written “file system” so I assume armbian is correctly installed on the Nvme ?
Also I have a question , is it possible to install two os on the same board ? like an android and an armbian ? I know that at work they have install gnome desktop and cinammon at the same time, but it s a normal computer.

Which Rock Pi board do you have? There is a version 1.3 model which has solder pads for a chip to enable booting from other than SD card or EMMC chip, but there is no chip installed. Version 1.4 has the chip installed. See:
If you’ve got the version 1.3 model you can buy one and solder it in if you’re brave enough. I did that and was able to get thing operational. But if you have the version 1.3 board and don’t add the spi flash, it’s not possible to boot from an nvme drive.